Showing results for 
Search instead for 
Do you mean 
Solved! Go to solution

MU moves before method



Can someone help me with this error. I know why I am getting it but I don't know how to fix it.


Background of model:

 I have a store that has product that moves to a buffer by a tablefile. My model runs fine then all of a sudden the product leaves before the method calls it and inturn I receive an error message (see attached file). How can I fix this? Why does this happen?


Thank you in advance!



Accepted by topic author Kbohara14
‎03-16-2017 08:27 AM

Re: MU moves before method

[ Edited ]

I guess the methcall has a problem with the formula.

Have you tried to calculate the same value in a local variable?

Interval := CoverBP1[1,row+1] - eventcontroller.abstime;

ref(deliverCover).methcall(interval, row +1);

Re: MU moves before method

Hello Alessio


Thank you for your reply!


I tried your suggestion but eventually I get the same error. Any other suggestions?



Re: MU moves before method

No, the methcall works fine with formulas.
What is CoverBP1[1, row +1]? Maybe it is not a real value...

if you upload your model maybe I can help you more.

Re: MU moves before method

Hi Alessio,


I found the problem. I was missing Sim in the absSimtime.


Thank you very much for your reply and help!