Cancel
Showing results for 
Search instead for 
Did you mean: 

Model Crashes when trying to Record Video in Windows 10 Pro

Genius
Genius

Hi,

 

I am trying to make a video of my model in Windows 10 Pro, but I am getting this error and then the model crashes. I've tried the Xvid codec and the Windows Video 1 codec.

 

I have no problem recording a video on a Windows 7 Pro machine, but unfortunately I need to record the video on the Windows 10 machine because it is connected to a PLC that the model needs to communicate with.

 

Any ideas? Is this a known Windows 10 issue perhaps?

 

Best,

 

EMM

9 REPLIES 9

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Genius
Genius

Never mind the Windows 7 machine working... Just tested it and got the same error.

 

It must be this model. I'm not sure what I can share publicly, so I have attached a copy of the model that I ripped all of the objects and drawings out of.

 

Any help would be Greatly Appreciated!

 

Thankyou! 

 

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi EMM,

 

this model is somewhat of a mystery for me:

Firstly, I do not get your crash. Not with those video codec, not with another one. I checked both the exact build you had (it is mentioned in the title bar of your call stack) and the current build. Same here: Neither one crashes.

Then, I was surprised by the lack of objects in 3D. I found out that the model is in the exact same state as that you encountered about a month ago - is it possible that this is the same model (meaning that you continued to work on the one from last time)? The model at least has two registered crashes and one of them was in the middle of copying something (I do not know what it was - just that this was last life sign of the model when the crash copy was created) - and this could lead to virtually anything!

Short of a better explanation, I would guess that this was the cause of the problem with the graphics loss. And it would not surprise me if we might find out one day that there is a common cause for this video recording crash and the memory copy crash in the model's history.

 

All in all, my best suggestion is to create a new model (or at least a new 3D part of the model) and see whether you encounter any of the problems again.

(To create a new 3D part, deactivate 3D on the Window ribbon, do not save your model at that time, save your model with a new name and restart the 3D works from there.)

Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Genius
Genius

Hi Peter,

 

Yes, this is the same model as last time.

 

I followed your explination on how to rebuild the 3D and the video recording appears to work flawlessly. Unfortunately, I had a lot of custom 3D objects in this model (see Sensor Graphics). I used code to copy in 3D graphics from jt files. It sounds likely that this crash occured somewhere in that process. So I will have to rebuild them all... That's probably lower on my priority list right now, but I'll get around to it.

 

Thank you for your support! I really appreciate it!

 

EMM

Highlighted

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi EMM,

 

we discussed your problem and came to one other possible cause: Could it be that you have your window has a pixel resolution of more than about 2 million dots? (e.g. more than 2000 x 1000) If so, could you please try to reduce your window size and examine whether the crash disappears?

If so, please tell us Smiley Happy

Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Genius
Genius

Wow! That seems to work. I'll have to try it on the Windows 10 machine. 

 

tenor (2).jpg

 

 

 

 

 

 

 

#MINDBLOWN

 

Any thoughts as why the model would crash when trying to capture more than 2000x1000 pixels?

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Genius
Genius
Okay, so after making that video at a smaller dpi... I can now record full screen, which with the cropping of the toolbar equates to 1906x574

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Siemens Phenom Siemens Phenom
Siemens Phenom

We discussed your problem and regardless of whether we were able to reproduce it, we tried to cover some potential problems - and this was the only one we could find.

That is a bug in our software which will be fixed in the next maintenance packs (unfortunately, we just released them you might need to wait a bit to actually get the next packs - if you can contact support, you might be able to get a hotfix with that bugfix).

Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Genius
Genius
Thank you so much for your support! Impressed to hear that the fix is already on it's way.

I've just installed 13.0.4 and 13.1.1 Updates. Do you know if it is included in those, or is it still out there?

Re: Model Crashes when trying to Record Video in Windows 10 Pro

Siemens Phenom Siemens Phenom
Siemens Phenom

No, I am sorry, they have just been released before this was detected.

Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution