Showing results for 
Search instead for 
Do you mean 
Reply

OPC UA connection with Plant Simulation 13.1.

We are doing school project where we need to establish a connection between TIA portal and Plant simulation using OPC UA interface. We are not using real PLC. So far we have been able to create OPC UA server which can be seen in both Siemens OPC scout and other test client. Both "Security policy" and "Message security mode" have been set to "None" in OPC UA Server. The problem is that when adding server name to OPC UA interface in PS and trying to set OPC UA to active, we get Error code (0x8001000). With OPC DA interface we had no such problem.

 

We appreciate any help we could get!

4 REPLIES

Re: OPC UA connection with Plant Simulation 13.1.

Hello,

please use the server name as documented in the online help:

OPCUA_ServerNameSyntax.png

After the prefix you have the numeric IP address from the location, where the server is running,

then the colon followed by the port number used for the communication. The port number for a OPC UA server on a real PLC or a virtual PLCSIM Advanced instance from Siemens is defined in TIA portal as OPC setting in the PLC hardware configuration.

 

Good luck and have fun

gepi

Re: OPC UA connection with Plant Simulation 13.1.

Thank you for your answer, gepi!

 

We have tried that already. Server name is in that exactly same form as in help shows and the port number is correct. We are pretty sure that it's not matter of wrong server name. When typing server name in wrong form it gives different kind of error-message.

It is hard to troubleshoot this issue because the error doesn't tell anything else but "connection failed" and the error code can mean almost any problem.

 

JeremiahCastle

Re: OPC UA connection with Plant Simulation 13.1.

Hi,

as the server address is ok we need to find a better solution Smiley Indifferent

Can you please explain, wich kind of OPC UA server you are using?

Regards

gepi

Re: OPC UA connection with Plant Simulation 13.1.

Hi,

 

Another student here working with the same school project.

 

We are using Siemens WinCC Advanced RT's "Operate as OPC server"-feature.

Using "opc.tcp://127.0.0.1:4870" as IP-address we can find OPC server using Siemens OPC Scout V10 and browse tags with it, but when trying to use same IP-address with PS 13.1, the error pops up. We also tried to use computers LAN IP-address (192.84....) but it did not make any difference.

I attached picture of our OPC UA server settings, if they could provide some information.

 

opcSettings.png

 

Regards

aavee