Cancel
Showing results for 
Search instead for 
Did you mean: 

Part leaves SingleProc without calling ExitControl

Creator
Creator

Hi,

 

in my model I have a SingleProc which after processing transfers a part via method to another station. The SingleProc has controls just as easy as this:pic1.JPG

 

print "front"
@.move
print "rear"

However, the part is moved to the next station without triggering the exit control.

 

When I put a buffer in front of the station, eveything works fine and both controls are triggered. Without buffer only the front control is executed, but the exit is just ignored.

 

Is there someone who can explain this behaviour? As I also encountered this on one more buffer in the same model, I am maybe missing something basic here.

 

Plant Simulation is V14.0

 

Best regards and thanks a lot in advance!

4 REPLIES

Re: Part leaves SingleProc without calling ExitControl

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello,

the first instruction of the exit control calls the entrance control of the following station. Then the second instruction of the exit control is performed: Please use the entrance control

print "front of ",?

and the exit control

@.move
print "rear of ",? 

Regards,

Peter

Re: Part leaves SingleProc without calling ExitControl

Creator
Creator

This doesn't help. Still only the entrance control is called. Is this maybe a bug?

Re: Part leaves SingleProc without calling ExitControl

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hello,

 

Try putting the breakpoint on the exit control and check. Better yet post the model if possible

 

Regards,

-varun

Re: Part leaves SingleProc without calling ExitControl

Creator
Creator
Thanks for your efforts. I will follow up on this after the Chinese Spring Festival.