Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Pick and Place Robot Buffer Problem

Pioneer
Pioneer

Hi,

 

I had already done a Pick and Place Robot with Exit Strategy and using Methods for both the Exit Strategy and Target (for the Pick and Place Robot). I wanted to replicate that in this model. I want RobotC to take it from Laser to OptionalGage to Buffer. Then I want the RobotC to wait while the product goes through to TackDE by itself. Then I want RobotC to take the product again and move it to BufferingConv. I tried to use a similar technique but it doesn't work. I also tried to code Laser differently but it didn't work so I commented it out. Is there something about wanting the robot to wait that is causing a problem? Or am I somehow using the Buffer tool wrong? I've attached the example below and the code I used for each of the methods. I put MLaser in the Exit Strategy for Laser, MOptionalGage for OptionalGage, MTackDE for TackDE, and MRobotC in the Target area for RobotC. Thanks in advance!

12 REPLIES

Betreff: Pick and Place Robot Buffer Problem

Gears Phenom Gears Phenom
Gears Phenom

I don't think you can set the destination of RobotC to BufferingConv since that is not connected to RobotC with a connector.

____________________________________________________________
Alex Dilg, Consultant at SimPlan AG (www.SimPlan.de)
This post was good and/or helpful to you? Please provide some Kudos, thank you!

Re: Pick and Place Robot Buffer Problem

Phenom
Phenom

have a look

Re: Pick and Place Robot Buffer Problem

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello,

 

I have attached a model where I also implemented something similar to what is shown in your picture. I think the issue is that you don`t set the robot to move to your "TackDE" station. You can take a look at the entrance and exit strategies in the stations and the robot in my model. Once you start using an exit strategy to move a MU between stations using a robot, it is better to set every destination for that robot for every station that is using an exit strategy involving this robot. 

Kind regards,

Igor
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution


Betreff: Pick and Place Robot Buffer Problem

Pioneer
Pioneer

After posting this I revised my model and corrected the connectors but it still doesn't work

Re: Pick and Place Robot Buffer Problem

Pioneer
Pioneer

Could you attach a picture instead? Your version is a higher version than mine (12.0) so I'm not able to open it, thanks!

Re: Pick and Place Robot Buffer Problem

Pioneer
Pioneer

Could you attach a picture instead? Your version is a higher version than mine (12.0) so I'm not able to open it, thanks!

Re: Pick and Place Robot Buffer Problem

Phenom
Phenom

Here you are

 

m0 is the pullcontrol method of the robot

 

Unbenannt.png

Re: Pick and Place Robot Buffer Problem

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello,

 

here is my model also in version 12.0.

Kind regards,

Igor
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution


Re: Pick and Place Robot Buffer Problem

Pioneer
Pioneer

Attached is a file with an isolated view of my problem. My specific problem is that I want the MU to go from Buffer to TackDE on its own, but program RobotC so it picks it up at Tack DE after it's done. I want it to follow the way I set up the connectors.