Cancel
Showing results for 
Search instead for 
Did you mean: 

Plant Simulation V12.1 crash on init

Valued Contributor
Valued Contributor

Hello,

 

I'm not sure how I managed to crash the program, but it happened when trying to read an excel file, resetting the simulation, then trying to run it again and read the excel file again. During the init-phase of the simulation (it is during the init phase i read an excel file), this error popped up:

 

bug.png

 

Seems totally unrelated to the excel-file as it has a problem with some code related to the workerchart. Hopefully this helps in solving it for the next service pack.

4 REPLIES 4

Re: Plant Simulation V12.1 crash on init

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello ET_Boys,

 

I guess that in line 68 of the method switchRadioButton the statement is

TableFile.readExcelFile(File.xls)

Please check this line. Maybe you're right and it is not related to the xls file.

 

But why does it only happen when the xls file is read the second time?

It would be the best if we had the model and the xls file.

 

Regards,

Peter

Re: Plant Simulation V12.1 crash on init

Valued Contributor
Valued Contributor

Hello Peter,

 

the switchRadioButton method seems to be a method embedded within the workerchart object and something I can't view. I haven't been able to reproduce the problem yet, but sometimes crashes like this happen when resetting the simulation in the middle of call chains. It may be something as simple as this. I was debugging the init-stage of my model when it happened so it seems related to interrupting call chains for a reset.

Re: Plant Simulation V12.1 crash on init

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello ET_Boys,

 

your observation is right: The method switchRadioButton is part of the tool Workerchart.

In row 68 of that method there is a simple deletion of a tablefile.

How can that be the reason for this crash?

 

Can you upload the model?

 

Regards,

Peter

 

Re: Plant Simulation V12.1 crash on init

Valued Contributor
Valued Contributor

Sorry Peter I am unable to both reproduce the problem or upload the file due to an NDA. I guess this was a one-time occurrence when I resetted the simulation in the middle of some sort of callchain related to the workerchart and that specific method.