Cancel
Showing results for 
Search instead for 
Did you mean: 

Plantsim version 15 bug with worker controls

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

I have an issue with Request control, well all the controls sticking in the transport methods in the importer tab on version 15 not sure if that's a known issue? This happens when you try to have that method called in the request control or other controls in the worker section of the stations. It's there when you hit apply it but when you hit ok and go back into it, that control is no longer there.

 

Thanks

9 REPLIES 9

Re: Plantsim version 15 bug with worker controls

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

can you post your model?

Steffen Bangsow
freelance simulation specialist  
web: www.bangsow.eu
mail: steffen@bangsow.net

Re: Plantsim version 15 bug with worker controls

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Doesn't matter the model I've tried it in new one's but I can upload one model. On the importer tab no method sticks.

Re: Plantsim version 15 bug with worker controls

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

this is clearly a bug, you should report this to GTAC

 

 

Steffen Bangsow
freelance simulation specialist  
web: www.bangsow.eu
mail: steffen@bangsow.net

Highlighted

Re: Plantsim version 15 bug with worker controls

Gears Phenom Gears Phenom
Gears Phenom

Although interestingly, this happens for Source and Buffer, but it does not happen for the SingleProc... Smiley Indifferent

So this means as a workaround you can put a SingleProc with processing time Zero behind your Source and define your Importer-controls there.

___________________________________________________________
Alex Dilg, Consultant at SimPlan AG (www.SimPlan.de)
This post was good and/or helpful to you? Please provide some Kudos, thank you!

Re: Plantsim version 15 bug with worker controls

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

This model seem to be in a similar state as one of my own model was a couple of days ago (also v15). 

 

I had problems with the transportimp.brokerpath. No matter what I did, I couldn't set the brokerpath of several stations. I set the path, closed the station and opened it again, and it was gone. And it is the same in this model for the sources. By using an attributeExplorer it seems like the path still is there, but not visually seen in the station.

 

Since I was short on time, I just went back to a previous version of the model and continued work. Didn't run into it again.

Re: Plantsim version 15 bug with worker controls

Gears Phenom Gears Phenom
Gears Phenom

So the problem already exists when I open a new, empty model.

But you are right, the BrokerPath and Controls are not displayed in the dialog, but are actually still set when you look at the attributes (also directly without AttributeExplorer). Although setting a new Control via the dialog did not stick, but setting it via SimTalk remained (but was not displayed in the dialog).

Also, applying the dialog window which showed an empty Broker/Control field did then not result in a change/reset of the attribute values...

___________________________________________________________
Alex Dilg, Consultant at SimPlan AG (www.SimPlan.de)
This post was good and/or helpful to you? Please provide some Kudos, thank you!

Re: Plantsim version 15 bug with worker controls

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Yeah I chose going back to v14.2 newer to plant sim so didn't think of a work around or make sure it was still doing the method. Figured I'd report the issue just incase others had it and there was a fix/workaround.

Thanks 

Re: Plantsim version 15 bug with worker controls

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello plat_simulator,

This is a bug which will be fixed in 15.0.1.

Regards,

Ralf
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution.

Re: Plantsim version 15 bug with worker controls

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Wondering when the update will be out if you knew? Thanks