Cancel
Showing results for 
Search instead for 
Did you mean: 

SetupFor on ParallelProc

Legend
Legend

Hello,

 

I'm experiencing a crash in Plant Simulation 12.0.1 when setting up a parallelproc with SetupFor, please see the attached model.

4 REPLIES

Re: SetupFor on ParallelProc

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello Verbalins,

 

thanks for reporting this issue.

 

We can reproduce the crash. The reason is that the argument you give to the setupFor method cannot be mapped to an object. If you use the path to a MU which has the requested name it should work.

 

The crash will be fixed and the fix will be part of the next patch (12.0.2).

 

Regards,

Ralf

Regards,

Ralf
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution.

Re: SetupFor on ParallelProc

Legend
Legend
Thank you Ralf!

Re: SetupFor on ParallelProc

Legend
Legend
Additionally, it seems that trying to use a path to a class in the class library doesn't work. I tried using .MUs.Entity and that crashed. Instancing the MU in a temporary buffer and then using the instance as the argument for SetupFor worked in the ParallelProc.

Re: SetupFor on ParallelProc

Siemens Phenom Siemens Phenom
Siemens Phenom

Thanks for informing us about this problem.

 

Will be fixed in the next patch as well.

 

Regards,

Ralf

Regards,

Ralf
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution.