Cancel
Showing results for 
Search instead for 
Did you mean: 

System funktioniert nach Einschwingphase nicht

Pioneer
Pioneer

Hallo liebe Community,

 

ich habe das Problem, dass sobald ich eine Einschwingphase (im Ereignisverwalter, Statistik) eintrage, das Sytem nicht mehr richtig läuft. Ist die Einschwingphase vorbei, behalten die Teile, die bis dahin einen Status "warten" bekommen haben (da sie auf eine Freigabe nach dem Messen des vorherigen Teils warten) diesen und können keine Freigabe mehr erhalten.

Was könnte ich tun , um diesem entgegenzuwirken?

 

Danke!

Lipres

3 REPLIES

Re: System funktioniert nach Einschwingphase nicht

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor
schwer zu sagen, ohne Ihr Modell zu kennen. Aber Sie müssen bedenken, das die Statistik zurückgesetzt wird, z.B. der Wert statAnzahlAus wird auf 0 zurückgesetzt. Wenn Sie statistische Werte in Ihren Steuerungen verwenden, kann es dadurch zu Problemen kommen.
Steffen Bangsow
freelance simulation specialist  
web: www.bangsow.eu
mail: steffen@bangsow.net

Re: System funktioniert nach Einschwingphase nicht

Pioneer
Pioneer
Genau, dadurch, dass die Statistischen Werte auf 0 gesetzt werden kommt es zu dem Problem. Kann man dagegen steuern?

Re: System funktioniert nach Einschwingphase nicht

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

sie können die Methode einschränken, so dass sie nur zur Statistikzeit läuft:

 

if Ereignisverwalter.zeit > Ereignisverwalter.startStat then

 

--ihre Methode

 

end

Steffen Bangsow
freelance simulation specialist  
web: www.bangsow.eu
mail: steffen@bangsow.net