Cancel
Showing results for 
Search instead for 
Did you mean: 

Tank

Builder
Builder

hi everybody i have a probelm with my tank  "the inflow rate is less than the outflowrate" 

or the outflowrate of the source that come just before tank is 6.7 l/s and the outflowrate of the tank is 5.82 l/s when i open  the dialog window of the tank i read 3.630 l/s as current inflowrate !!!

15 REPLIES 15

Re: Tank

Siemens Phenom Siemens Phenom
Siemens Phenom
Is there a pipe between the tank and source? If so, check the flow-rate of the pipe.

Re: Tank

Phenom
Phenom

posting the model fragment , upon which your post is based,

 

would probably simplify and help the expertise.

 

 

 

 

Re: Tank

Builder
Builder

yes there is a pipe between the source and the tank whose the outflowrate is the same as the source but the source and the pipe belong to a sub-frame (separator) and the tank belon to the Top-frame  

Re: Tank

Builder
Builder

here are two pictures

Re: Tank

Siemens Phenom Siemens Phenom
Siemens Phenom
The pictures alone is not enough to go on. Can you share the model?

Re: Tank

Builder
Builder

ok

Re: Tank

Siemens Phenom Siemens Phenom
Siemens Phenom

It seems that PlantSim is clever enough to divide the outflow of a pipe evenly amongst all successors if the pipe is split in two. So while your source might pump out 6.8 l/s, each pipe connected to the first one only has a flow of half that ones, I.e. 3.4 l/s. 

 

This is not, however, a problem when two pipes are connected directly to a source, because then they both have the same outflow as the source.

 

The easiest fix in your case would then be to have two pipes from FluidSource with one interface each.

 

The Pipe logic exemplified:

Spoiler
PipeLogic.png

Re: Tank

Builder
Builder

i did what you said about the pipes but the fluidsource doesn't work! i don't know why

Re: Tank

Siemens Phenom Siemens Phenom
Siemens Phenom
Could you be a little clearer with how the source is broken? Does it pump too little? Too much? Not at all?

Also, I was a bit off in my earlier comment: If you have two pipes connected to the source, each pipe will have the same outflow as the value you put in the outflow filed in the source. However, the actual outflow of the source will be double.

Example: you set the outflow to 3 l/s and have two pipes. Each pipe will have an flow of 3 l/s.The current outflow rate of the source will however be 6 l/s. So PlantSim will still distribute the flow evenly, but the source will increase its own output so that the pipes will get the "correct" flow.