Cancel
Showing results for 
Search instead for 
Did you mean: 

Workers bahaviour

Experimenter
Experimenter

 

Hi all,


I have created a model in Plant Simulation v13 in which there are 4 OP (Operation) like in figure, formed by 2 SingleProcs and one or more Buffers. You can imagine it a series of 4 Chaku-Chaku lines. The task of the workers is to load/unload the SingleProcs.

 

PS1.jpg

 

Design:

 

  • Each OP has his dedicated worker, WorkerPool and Broker:
    • the Worker-1 is assigned  to the WorkerPool1 and managed by the Broker1 only for the OP10,
    • the worker-2 is assigned  to the WorkerPool2 and managed by the Broker2 only for the OP20, and so on…
    • Summarizing, each OP is fed by a specific worker that should work only in that OP.
  • Between each station is present a buffer: the buffer is the only item in common between the workers of two adjacent OPs.

 

Problem:

 

  • The workers are behaving badly, not working on their specific OP but working randomly on all the OPs. The simulation stalls whit this error:PS2.jpgThis because in the OP40, where should work only the Worker-4, all the SingleProcs are occupied by other workers (Worker-1 and Worker-2).

 

PS3.jpg

 

Where am I wrong?

 

Any assistance would be greatly appreciated.

Thanks in advanced.

4 REPLIES

Re: Workers bahaviour

Phenom
Phenom

Could you please post your model.

 

It makes it easier to dig for  than to guess, what causes the described behaviour.

Re: Workers bahaviour

Experimenter
Experimenter

Sure, here it is!

Re: Workers bahaviour

Phenom
Phenom

it seems, that you are overruling the brokers by moving the mus from the dummy object to

any worker (s. console output below)

 

Unbenannt.png

Re: Workers bahaviour

Experimenter
Experimenter

Yes, that was the problem! Thanks!