Cancel
Showing results for 
Search instead for 
Did you mean: 

worker obstacles

Valued Contributor
Valued Contributor

as below shown, the Workplace and the station. In 3D I have set the uniform scale as 0.2 ,but the worker  obstacles are still large then station.  In model  there are many station ,so worker can not through the station,   how can I set the obstacle is as large as the station ,  thank you very much捕获.PNG

 

 

 

6 REPLIES 6

Re: worker obstacles

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello,

 

the obstacle area has a fixed offset relative to the edges of your machine. You can`t change the size of this offset. But you can use the following workaround to get an "alternative" obstacle area using a "Barred Area" object to achieve such a change. This workaround is separated into three parts A, B and C. You will need to:

A: Make sure that your SingleProc is using "Graphics" as an option for "Obstacle for worker" instead of "Bounding Box". Now you can customize the obstacle area of your machine in its class.

B: Switch off the obstacle option for the graphics of your SingleProc. This is done so that you won`t have obstacle areas that are defined by each of the graphical elements of your machine. You can do this by grouping the graphics of the SingleProc class. Thus, this step has to be done only once and not for each separate graphic element.

C: Insert a "Barred Area" which is used as a new obstacle area for your SingleProc. You can now customize this area which acts as the new obstacle area of the machine.

 

Here are the instructions to achieve all that:

 

A:

1. Right click on your SingleProc and select "Edit 3D Properties...".

2. Navigate to the "Graphic Settings Tab" and select here for "Obstacle for worker" in the drop down menu "Graphics".

3. Click on "Apply" and then "Ok" to close that window.

 

B:

1. Open the SingleProc in your class library by right clicking it and selecting "Open in 3D".

2. In the now opening frame press ctrl+A.

3. With all parts selected except of the states (this is very crucial, as the following will not work otherwise) click on the "Edit" ribbon and there click on "Group" which is found in "Structure".

4. Right click on

your SingleProc now and select "Edit 3D Properties..."

5. Navigate to the "Graphic Settings Tab" and select here for "Obstacle for worker" in the drop down menu "None".

6. Click on "Apply" and then "Ok" to close that window.

 

C:

1. Next go in the "Edit" ribbon to "Insert Shape" and click here on "Barred Area".

2. In the following dialog type for "Width" 1.2m and the same for "Height", afterwards click on create, leaving the rest of the settings unchanged.

3. Insert the center of the area into the center of your SingleProc.

 

Now your "standard" SingleProc will have an obstacle area that has the same size as the station, as you can see in the attached picture. Every time you insert a new SingleProc you will have to go through the steps described in A to get this result again. Whenever you use this workaround you have to keep in mind, when setting your barred area, that Plant Simulation will automatically add 40cm at each side of this area. In this example, the length of a side of the barred area was entered to be 1.2m. But then this length will be prolonged by 40cm+40cm, 40cm at each side, which yields 2m. So your barred area won't have an area of 1.2mx1.2m but 2mx2m. This has the background that the human body has on average a width of 80cm. To make sure that a worker definitely will be kept away from a machine when e.g. walking down a narrow passage between two machines, this offset is added automatically by the software.

 

Kind regards,

Igor
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution


Re: worker obstacles

Legend
Legend

Hi Igor,

 

thanks for good explaination. i have also same problem (But in my case its Buffer instead of Singleproc)

Barred_Areas.PNGI follwed your all steps(A,b,C) but its still shows this error. I think, i made mistake in B Steps

((2. In the now opening frame press ctrl+A.

3. With all parts selected except of the states (this is very crucial, as the following will not work otherwise) click on the "Edit" ribbon and there click on "Group" which is found in "Structure".))........You said that.select all parts(ctrl+A) except states..what is the meaning of states.And when i open singleproc in 3d from class library (by clicking right click). In that case i have only one singleproc in that 3D windows.

 

Can you explain me onceagain if this is similar for Buffer also.

In attachment, you can check layout of only one frame in which shows error . But when i changed location of workplace then its working.But in real model i can't change location because its according to coordinate system.

 

i have onemore question,Do i have to follow these steps everytime when i will add new singleproc or buffer in my model?

Thanks in advance

Re: worker obstacles

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello,

 

the same procedure should also work for the Buffer, you can see my results in the attached picture. With the states I wanted to emphasize that when you use ctrl+A, they won`t be selected in contrast to the rest. You also should not try selecting them manually in addition to the rest. So after selecting your parts there is no further selection necessary. You will not need to repeat all of the described steps every time but only the steps described in A when you are inserting an object. An alternative is to apply the steps described in A not to an instance in your model frame but to the class of that instance. From here I can't tell why your model worked again after moving that workplace away, could you post your model here? 

Kind regards,

Igor
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution


Re: worker obstacles

Legend
Legend

Hi Igor,

 

I think that, why Models is working if i move workplace away from stations. Because there is obstacle near to stations(check it in attachment). if i will change positions of workplace then its working. But i don't know why there is so many obstacle in this particular subframe(in this subframe there are only 3-4 stations).But its shows more obstacle.check it in attachment.plz consider. In my model there is so many frames and subframe.

 

If these obstacle created because of object which are in other frame,then how can i delete

it.(Because my model contains --freely moving worker,workplace,somany frame,and subframe...))

Thanks

Schönes Wochenende

 

Obstacle without object1.PNG

Highlighted

Re: worker obstacles

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello,

 

as you said, objects that are situated in a subframe will act as an obstacle for the worker in the mainframe and vice versa. If you want to switch this behavior off, you can right click on your subframe and choose "Edit 3D Properties". Here you navigate to the "Graphics" tab and choose for "Obstacle for Worker" in the drop down menue "None". This way your objects in a subframe will not appear as an obstacle in the main frame.

Kind regards,

Igor
------------------------------------------------------------------------------------------------------
Did you like the answer? Then click the Thumbs Up button.
Did the answer solve your problem? Then accept the answer as solution


Re: worker obstacles

Legend
Legend

ThankSmiley Happy you so much.its working.