Showing results for 
Search instead for 
Do you mean 

Tech Tips & Tricks: How can I access Highcharts that requires highcharts-more.js file?

by Siemens Dreamer Siemens Dreamer on ‎02-24-2015 03:50 PM

Polarion 2014 introduced the Highcharts library enabling you to easily implement various kinds of charts such as bar, line, area, area spline, pie etc. In addition to these, there are also other types of charts like columnrange chart  (http://www.highcharts.com/demo/columnrange) – that require the  highcharts-more.js file. This comes out-of-the-box in Polarion 2014 SR2 and up, but if you cannot update to the latest version for some reason here is how such chart can be implemented in Polarion: What needs to be done is this:
  1. Stop your Polarion server
  2. Copy /com.polarion.alm.ui/phantomjs/highcharts-more.js to /com.polarion.alm.ui/webapp/ria/javascript/highcharts-more.js
  3. Edit com.polarion.portal.jetspeed_3.8.0\webapps\jetspeed\index.jsp and add:<script src="/polarion/ria/javascript/highcharts-more.js?buildId=<%=com.polarion.portal.jetspeed.gwt.GWTServletProxy.getBuildId()%>" type="text/javascript"></script>
  4. Edit: com.polarion.alm.wiki_3.8.0\src\main\webapp\skins\sidecar\htmlheader.vm and com.polarion.alm.wiki_3.8.0\src\main\webapp\skins\sidecar\printpageheader.vm and add this line:<script src="/polarion/ria/javascript/highcharts-more.js$xwiki.getBuildNumberQueryString()" type="text/javascript"></script>
  5. Start your Polarion server.
Voilà! Charts from highcharts-more.js are now displayed in Polarion.

Banner: It's all about solutions - Polarion Silver and Gold Support