Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

NX 10.0 Not showing in "Integrations"

After installing NX 10.0, and trying to run an NX 9.0-created line item in RS Engineer, I got a dialog that said "Selected NX version and Environment Variables do not match - Part processing not allowed.  Please set the correct environment variables and restart the application"

 

Sure enough, the environment variables were changed by NX10.  But I want to run the project in NX10, so changing the Env vars back to 9.0 is counter-productive.

But I cannot change the profile/Options/Integrations/NX to NX 10.0, because it doesn’t appear in the drop-down.  If I try to change the profile/Options/Additional Settings “NXBaseDirPath” to the correct place, it doesn’t “take”, just puts it back the way it was.

If I edit the ini file to have the correct things, NX 10 does start, but the whole process then hangs without opening the assembly.

 

Note that one potential significant change is that NX 10 is installed on the D: drive, where NX 9 is installed on the C: drive.

 

Any advice appreciated.

1 REPLY
Solution
Solution
Accepted by topic author jgg
‎11-04-2016 02:01 PM

Re: NX 10.0 Not showing in "Integrations"

If you want to run multiple versions of NX on the same machine the very easiest way to do this is:

1)      Open up an NX <X> command window

2)      Cd to RS install folder

3)      Run RS

 

If you are switching a lot, you can also create batch files that set the NX <X> environment variable for each version.  You still have to run that batch file and make sure that the env vars are set properly before starting RS.  Most find the first method by far the easiest.

 

If this doesn't solve your problem, please submit an IR through GTAC for support:

How to Open an IR with GTAC