Reply

Changing default units


Hello everybody,
I just started using free2d and I can't figure out how set all units to default
to US.
My Area Rep was kind enough to send the attached Word document, but the files listed
in the document don't exist for my installation.
I'm guessing I have a newer version of free2d: Ver 100.00.00.133
Thanks in advance,
-Barry

8 REPLIES

Re: Changing default units

I have the same question but I guess no one knows!!!
Great

Re: Changing default units

I have the same question but I guess no one knows!!!
Great

Aaron,
If you haven't seen Rick's reply to Barry's original question here it is. It may have the answer you are looking for.
"Barry,
I'll provide information for this topic and your previous topic.
Units for distance are set up by default based on the template you use.
We now provide different templates based on the different standards (ISO,
ANSI, JIS, etc.).
When you install Solid Edge, you specify the standard you use most often
(ANSI).
Installation will set the proper template as the default based on which
standard you choose.
The proper template is copied into the "Solid Edge 2D Drafting\template"
folder.
If you specify ANSI, the 'ansi draft.dft' file is put into this folder.
Also, the 'Create 2D Drafting' link on the startup page is configured to use
this template file.
All the templates for all the standards are delivered with the product. Look
in the "Solid Edge 2D Drafting\template\more" folder.
If you need to create a new draft file based on another standard, you can do
this by clicking on the application button in the upper left and then click
on the 'New' command.
Click on the 'More' tab in the dialog. Click on the template you want to
use. Click on OK. You will get a new draft file based on that standard,
which includes units.
There are options in Solid Edge that you can modify to change the units, but
most likely you just want to set 2D Drafting up to use the proper default.
There is more to standards than just units. Dimensions display differently
based on standards. There are other differences.
Uninstalling and reinstalling with the correct standard is the easiest way
to accomplish the proper standard. You do not have to know all the settings
to change.
As for your question about line thickness. The thickness is not a measurable
item. Therefore, we have chosen to use a single unit type for thickness
across all standards.
My question is; Why are you concerned with thickness?
Regards,
Rick B."
Hope this helps some.
Ed

Re: Changing default units

In addition to the isodraft.dft file that was put into the the template folder during installation, there are also 7 other iso files. Instead of reinstalling the software is it possible to just replace those files with there ansi equivalents?

Thanks Rich

Re: Changing default units

Rich,
All you need to be concerned with is the .dft file.
Under the \template folder there is a \more folder.
Copy the 'ansi draft.dft' file form the \more folder to the \template
folder.
Rename the 'iso draft.dft' file to 'iso draft.dft2' so the system does not
see the file.
Rename the 'ansi draft.dft' file to 'iso draft.dft'.
You now have the ANSI template renamed to ISO.
This should work, but you are customizing the template to get around a
installation issue.
Regards,
Rick B.

Re: Changing default units

Rick
What would happen if I did not rename the ansi file to iso?

Rich

Re: Changing default units

When you click on 'Create 2D Drawing' on the startup screen (no document
open), it will still create an ISO standard drawing.
This will be a metric file.
You can leave everything the way it is and use File-New and navigate to the
'More' folder and select the ANSI template when you want to create a new
drawing.
Regards,
Rick B.

Re: Changing default units

I'm having the same issue. I need inch dimensions. So the options are to munge the file names or reinstall to change this?

Re: Changing default units

Thre is no single option that changes the setup from metric to inch.
This is done during installation.
It is much easier to simply uninstall and reinstall specifying ANSI as the
default style.
Or, do not use 'Create 2D Drawing' on the startup page. Use the 'New'
command under the application button.
On the file "New' dialog click on the More tab. Then click on 'ansi
draft.dft' and then the OK button.
This will create an inch file.
Regards,
Rick B.