Dimensions and Scaling

N/A
Using ST5;

I have been doing a drawing for a new combined summerhouse with an adjoining hut to be used for my slightly downsized wood workshop!

I did the drawing on the 2D-model page at actual size and I also added dimensions to the drawing on the 2D-model area.

When adding the drawing to a background at an appropriate scale, the dimension text is also scaled to the extent it is unreadable!

Would it be better to add the dimensions in on the background so that they are the appropriate sizing when printed?;

Either 2.5; 3.5; 5; or 7mm in height

Is there another, or better way to do it? HELP please.

George
10 REPLIES

Re: Dimensions and Scaling

Esteemed Contributor
Esteemed Contributor
Not sure how you did the "background"... Did you add it as a block to the 2D model sheet or did you place a 2D Drawing View on a Working Sheet? If using the Working sheet and 2D Drawing View, you can place your dims in the 2D Model sheet but put them on the Auto-Hide layer. Then in the Working Sheet, use Retrieve Dimensions to pull them in at the correct scale (scale is automatic).

Thanks,
Ken

Production: ST9 MP7
Testing: ST10

Re: Dimensions and Scaling

Community Manager Community Manager
Community Manager
Go into the 2d Model View properties and go to the General tab. Uncheck the option 'Scale dimensions and annotations'.
You may have to adjust the size of the 2D Model View border by clicking on the view and dragging the edges of the border.

Regards,
Rick B.

Re: Dimensions and Scaling

N/A
2D Model was attached to Sheet 1, or Background, whichever had the drg. border on it. I used the 'Tablet' command for placing and scaling the 2D-model.
Text on new layout stayed at height of '2D-model'. Since I drew drawing lines true thickness of wood slats at 44mm, the first print I attempted was mainly just black ink!!
Tabs I see on my 2d desktop where drawing commands are, are
HOME; TABLES; INSPECT; TOOLS & VIEW:
I can't see a GENERAL tab

Re: Dimensions and Scaling

Community Manager Community Manager
Community Manager
OK. You have drawn geometry in 2D Model. The geometry is at 1:1 scale. We will call this your model.
Now click on Sheet1 and you will see a drawing with the border displayed.
Did you place a 2D Model view on Sheet1? This will allow you to place a view of your model on a drawing.
While on Sheet1 click on the 2D Model View command. It will display your model and allow you to fence the geometry you want to see in the 2D Model View on Sheet1.
Once you place the view, you can click on the view and change the scale of the view in the modify command ribbon that is displayed.
Get to the point where you can see the 2D Model View on Sheet1 and we can go from there with more information.

Regards,
Rick B.

Re: Dimensions and Scaling

N/A
Hi Rick,
Thank you for responding.
I am a bit beyond this point; I have the 2D-model showing at scale 1:50 after trying a variety of scales and fiddling about a bit.
I had also cropped the edges a bit by clicking on the view in 'sheet 1' so it looks a bit nicer and in a better location in relation to the background.
What's next?
George

Re: Dimensions and Scaling

Community Manager Community Manager
Community Manager
George,
I suspect the issue now is the scale of the dimension text. You now have a 2D Model view and you see the dimensions on Sheet1 that you placed in 2D Model. The dimension text is scaled the same as the 2D Model View. That is the view has a scale like 1:10 or some other scale. The text display is tiny because of the scale of the view. Is this your problem? If this is the case, click on the 2D Model View. You will see the command ribbon for the 2D Model View Modify command. Click on the Properties button in this command ribbon. This will display the Properties Dialog for the selected view. Click on the General tab in the Properties Dialog. Uncheck 'Scale dimensions and annotations'. Click on OK. The dimensions will change such that they are not scaled by the 2D Model View scale. You may have to adjust the cropping boundary by dragging the handles when the view is selected.

I hope this resolves your problem.
Regards,
Rick B.

Re: Dimensions and Scaling

N/A
I see what you mean now about the - Uncheck 'Scale dimensions and annotations'.
Unfortunately the dimension leader lines and text went completely off the drawing!!
I had scaled the text up using the Text Scale on the Text Command box on the '2D model'!
I had to do something like this since the text height came up at 3.5mm!
My Layout size is 4200mm x 2400mm. (Overall drawing size will be about 3 times each dimension once the different views and detail drawing parts are included - unless I break the view up and put them on different drawings?)
When my sketch was 'Fitted' to the window I couldn't even see the text in the 2D model view!
It seems I am between the devil and a high place on this issue
If I do the Uncheck 'Scale dimensions and annotations', I have to leave the dimensions 'unscaled' in the 2D model view in order to see the text OK in the 'sheet 1' working view.
If I leave the 'Scale dimensions and annotations' checked, I need to scale the dimensions in the 2D model view and I may be able to get a good enough scale in the 2D model view that I can see the dimensions OK in the 'Sheet 1' view as well!!
Thank you for taking the time to go through this with me - Some of the grey cells in the brain are beginning to fire up again.
It is just that there are so many aspects and commands to this 2D CAD that it seems like I will never pick it up again. (Like remembering to keep specific parts of the drawing on a specific layer. )
I think I am as far as I can go with this topic - for the time being until it raises its headed in a slightly modified way later.
George

Re: Dimensions and Scaling

Community Manager Community Manager
Community Manager
George,
Work with getting the dimensions to look correct in the 2D Model environment first. You state that when you fit the geometry in 2D Model, you could not read the dimension text. This is because, as you state, the dimension text is small relative to the overall size of the geometry. When working with large models, you need to account for the dimension text size. You do not have to use the Text Scale on the dimension ribbon bar to adjust the text size. this only applies the change for the selected dimension. You can modify the text size in the Dimension Style. When you do this the change will apply to all dimensions using that style. Click on a dimension to see what the dimension style is. there is a combo box on the modify command ribbon the will have ISO, ANSI, etc. in it. This is the style that is being used. In the Dimension command group there is a Styles button. Click on that button. Click on Dimension in the Style type list. Click on the style being used in the Styles list. Click on Modify. Click on the Text tab in the Modify Dimension Style dialog. Change the Font size to something that is appropriate for your model size. Click on OK. Click on Apply. The text size on all dimensions using that style will change. This should help with the dimension display.

Regards,
Rick B.

Re: Dimensions and Scaling

N/A
Thanks again Rick,
Super - There are still a couple of fiddly bits within the process you mentioned that I have to get used to, but I am happy for now. I made a new style for this project based on the ISO style and have got to better way of doing it. I just hope I retain this info in mind for future drawing projects so I can get the text looking just right for 2D model view. The sheet 1 view looks OK as well now since the text there looks what would be standardized size for a design drawing!
George
Can we close this thread now?