Editing Autocad .dwg file with Solid Edge 2D

N/A

Dear users,
I need to edit existing autocad drawings (.dwg) but when I save .dft file as .dwg,
the text and some properties are altered.
Can anyone advice me on how I may edit .dwg files and save them so they will retain
their formats and properties?

Regards,
Allan
7 REPLIES

Re: Editing Autocad .dwg file with Solid Edge 2D

N/A
Allan,
Can you be more specific on what you are seeing?
Keep in mind that when a DWG file is opened in Solid Edge, the AutoCAD data
types are converted into Solid Edge data types. Then when you save back out
to AutoCAD, the Solid Edge data types are converted into AutoCAD data types.
Some simplification of data may happen when doing the conversions. But, the
conversions should maintain their proper appearance.
Regards,
Rick B.

Re: Editing Autocad .dwg file with Solid Edge 2D

N/A

"Ricky Black" wrote:
>Allan,
>Can you be more specific on what you are seeing?
>
>Keep in mind that when a DWG file is opened in Solid Edge, the AutoCAD data
>
>types are converted into Solid Edge data types. Then when you save back out
>
>to AutoCAD, the Solid Edge data types are converted into AutoCAD data types.
>
>Some simplification of data may happen when doing the conversions. But, the
>
>conversions should maintain their proper appearance.
>
>Regards,
>Rick B.
>
>

Good day Rick,
Thanks for your prompt response, I have created the attached document showing the
specific problem I am encountering. Please see if you can help advice how I may
avoid this problem.
I would like to be able to edit existing AutoCAD drawings so as to expedite some
drafting work for my engineers to review designs while not having to have the drafters
to touch-up my Solid Edge outputs.
Looking forward to your response.
Regards,
Allan
Regards,
Allan

Re: Editing Autocad .dwg file with Solid Edge 2D

N/A
Allan,
Do you know what font was used for the text in the ACAD file? There is a
page in the AutoCAD translation wizard to map an AutoCAD font to a Solid
Edge font. When you do a file open, click on the Options button on the
dialog. You can look through all the options.
Regards,
Rick B.

Re: Editing Autocad .dwg file with Solid Edge 2D

N/A

G'day Rick,
I have checked and teh ACAD Font in ACAD file is ISOCP which in teh 'Options' is
translated to Arial Font in Solid Edge. The output of these setting has produced
drawing text as attached in my ealier posting.
can y ou help adcie how I can correct this so SE will not change fonts when translating
file from ACAD to SE?
Regards,
Allan
"Ricky Black" wrote:
>Allan,
>Do you know what font was used for the text in the ACAD file? There is a
>page in the AutoCAD translation wizard to map an AutoCAD font to a Solid
>Edge font. When you do a file open, click on the Options button on the
>dialog. You can look through all the options.
>
>Regards,
>Rick B.
>
>

Regards,
Allan

Re: Editing Autocad .dwg file with Solid Edge 2D

N/A
Allan,
Is the ISOCP font in AutoCAD a .shx (Shape file font) ot a .ttf (True Type
Font)? On my machine I have an ISOCP true type font.
The reason you are getting Arial font in Solid Edge is because Arial is the
default to use during translation. In the translation options you map the
AutoCAD fonts to a Solid Edge font. When you click on the AutoCAD file to
open, click on the Options button on the file open dialog. Go through the
options paged by clicking on the Next button until you see the font mapping
page.
You must map your ISOCP font to the same font to use in Solid Edge.
You must save the customized translation options file to a unique name. It
will not let you overwrite the default.
Regards,
Rick B.

Re: Editing Autocad .dwg file with Solid Edge 2D

N/A

Hi Ricky,
Thanks for all your help thus far, but I am still not able to identify which AutoCAD
font should be mapped to which SE font.
I have attached a file for you to see if you can help determine which SE font I
should map to. Look at the bottom right corner of drawing where the NOTES are.
Please delete drawing after you hopefully have determine what mapping is required.
thanks.
Looking forward to hearing from you.
Regards,
Allan
"Ricky Black" wrote:
>Allan,
>Is the ISOCP font in AutoCAD a .shx (Shape file font) ot a .ttf (True Type
>
>Font)? On my machine I have an ISOCP true type font.
>
>The reason you are getting Arial font in Solid Edge is because Arial is the
>
>default to use during translation. In the translation options you map the
>
>AutoCAD fonts to a Solid Edge font. When you click on the AutoCAD file to
>
>open, click on the Options button on the file open dialog. Go through the
>
>options paged by clicking on the Next button until you see the font mapping
>
>page.
>
>You must map your ISOCP font to the same font to use in Solid Edge.
>
>You must save the customized translation options file to a unique name. It
>
>will not let you overwrite the default.
>
>Regards,
>Rick B.
>
>

Regards,
Allan

Re: Editing Autocad .dwg file with Solid Edge 2D

N/A
Allan,
There are a couple of things about this file.
One, in the font map of the AutoCAD to SE translation wizard, I mapped the
following. This is the best mapping I can find for these.
iso3098b to Solid Edge ISO
iso3098b.shx to Solid Edge ISO
isocp.shx to Solid Edge ISO
When I open the file with AutoCAD, it substitutes simplex.shx for these
fonts.
I don't know what 'vwshapes.shx' represents so I left it mapped to Arial.
AutoCAD did not know how to map this font either.
Two, The text in question is MTEXT in AutoCAD. For some reason the internal
formatting strings from the MTEXT are not being parsed properly. This is the
first file I have seen with MTEXT in a long time. I have logged a problem
report with development on this issue. MTEXT is converted into Solid Edge as
indifidual text strings. All you can do for now is to ungroop the strings
and clean up the formatting strings that were created by translation. You
can also get the string lengths to look better by setting the aspect ratio
in the text properties to .9. Right click on the text box and click on
Properties. Click on the Paragraph tab. Change the aspect ratio there to .9.
Regards,
Rick B.