MOVE ST8 CUSTOM SETTINGS TO NEW PC

Genius
Genius

Sean, this is a question as a followup to: ADVICE ON BUYING NEXT PC. I’m about to buy that new PC using the advice you provided.

 

I know that I’ll have to re-download ST8 to the new PC. Since I have saved the .exe file in MY DOCUMENTS which I will copy over, I’m sure that will make it easier to start the download. However, is there a way to capture my custom settings from the old PC to the new PC?

 

Thanks,

Ron

 

9 REPLIES

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Siemens Phenom Siemens Phenom
Siemens Phenom

For your user settings:

 

  1. Use a registry editor to export the following hive:

HKEY_CURRENT_USER\Software\Unigraphics Solutions\Solid Edge\Version 108

 

  1. In Windows Explorer copy the following folders:

C:\Users\<user id>\AppData\Roaming\Unigraphics Solutions\Solid Edge\Version 108

 

If you have created your own file templates and/or modified the Solid Edge preferences then copy the following:

 

C:\Program Files\Solid Edge ST8\Preferences

C:\Program Files\Solid Edge ST8\Template

 

On your new system copy and import the above captured settings/preferences.  Your preferences and settings should now be copied over.

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Genius
Genius

Dave, I got my new pc and sucessfully downloaded ST8 along with taking the steps you suggested for capturing my settings and preferences.  It works except for on thing.  Whenever I open the software, I get an Error message saying "CANNOT CREATE FOLDER". 

 

When I hit OK, the file opens and there aren't any other problems that I've seen so far.  It's not a big deal but it would be nice to understand why.

 

Thanks,

Ron

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Siemens Phenom Siemens Phenom
Siemens Phenom

Ron,

 

  1. Exit out of Solid Edge
  2. In Windows Explorer rename the "%APPDATA%\Unigraphics Solutions" folder to make a backup copy.
  3. Restart Solid Edge

If this resolves your issue we can discuss the next step.

 

If this doesn't resolve your issue, delete the newly created "%APPDATA%\Unigraphics Solutions" folder and rename your backed up folder to "%APPDATA%\Unigraphics Solutions".

 

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Genius
Genius

Dave, to avoid my confusion, let me repeat what I think you’re saying:

 

I assume that the path you mean is: C:\Users\Ron\AppData\Roaming\Unigraphics Solutions.

 

I first make a copy of folder “Unigraphics Solutions” located in the %APPDATA%. Let’s say I name the copy: “Unigraphics Solutions Backup”. I leave the original and copy in the %APPDATA% directory. Then I open SE and see what happens.

 

If the problem persists, I delete the original “Unigraphics Solutions” folder and rename the copy back to the original name of “Unigraphics Solutions”.

 

Is this correct?

 

Thanks,

Ron

 

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Siemens Phenom Siemens Phenom
Siemens Phenom

Close :-)

 

Backup your "C:\Users\Ron\AppData\Roaming\Unigraphics Solutions" to say "C:\Users\Ron\AppData\Roaming\Unigraphics Solutions - Backup".

 

Then delete "C:\Users\Ron\AppData\Roaming\Unigraphics Solutions".


The start Solid Edge -- the "C:\Users\Ron\AppData\Roaming\Unigraphics Solutions" will be recreated.

 

If the issue is gone then there is a problem with the data in your original %APPDATA% folder which is currently named "C:\Users\Ron\AppData\Roaming\Unigraphics Solutions - Backup".

 

If the issue still exists then we need to look elsewhere.

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Genius
Genius

Dave, I could not resolve the problem following your directions.  What's next?

 

I don't know if what I reported just this am re CAN'T CLOSE INDIVIDUAL FILES is related or not.  I'm finding other little things.  For example:

 

1. The software seems to go to sleep and not respond to commands.  Hovering with the mouse cursor shows no highlighting.

2. The cursor Quick Pick is very slow to non existent. When this happens, if I open the Intellisketch Options and close it, that sometimes wakens the QP.

 

Thanks,

Ron

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Siemens Phenom Siemens Phenom
Siemens Phenom

Hmm, if the entire Solid Edge is acting "wonky" I personally would be inclined to uninstall it and reinstall again.

 

Before installing make sure that UAC is disabled, that you have deleted everything out of the %TEMP% folder, and that you temporarily disable your anti-virus for the install.

 

When installing make sure you right-click ->Run as administrator over the installer file.

 

Also, make sure that you have set your page file size to be optimal for Solid Edge [2 X RAM].  See the attached instructions.

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Genius
Genius

Dave, I haven’t acted on your last recommendation. I have reason to suspect that I was having a system problem rather than something unique to SE.

 

I’ve been using SE without any of the aforementioned problems. I do notice some strange behavior around closing files as I had previously reported. But since you implied that this is a bug which will be fixed on the next update, I’m assuming all the little idiosyncrasies I’m seeing around file closure and switching between files are related.

 

However, I still have this initially reported problem of CAN’T OPEN THIS FILE popup when I first open SE. But if a new download is the only fix and I’ll lose my custom settings, I’ll live with this popup rather than incur the time to recustomize.

 

Thanks,

Ron

Re: MOVE ST8 CUSTOM SETTINGS TO NEW PC

Genius
Genius

Dave, after further use, I continued to have the following intermintently:

 

1. The software seems to go to sleep and not respond to commands.  Hovering with the mouse cursor shows no highlighting.

2. The cursor Quick Pick is very slow to non existent. When this happens, if I open the Intellisketch Options and close it, that sometimes wakens the QP.

 

If I changed windows and came back to the file, it would be ok.  So I decided to follow your directions from last week.  

 

The only thing that I didn't understand was the last instruction restated here:

When installing make sure you right-click ->Run as administrator over the installer file.

There wasn't any time during or after the installation process that gave the opportunity to do this.  I executed the installation from the .exe file that I had in MY DOCUMENTS folder.

 

After the reinstall, I still get the popup window stating "CANNOT CREATE FOLDER" (please ignore my mistatement from earlier that called this popup "CAN’T OPEN THIS FILE"). I did do the UNINSTALL but still recovered all my customizations from before. 

 

Please advise.

 

Thanks,

Ron