Part Revisions don't show in assembly drawing??

N/A
I'm using the 2D Free ST5 under Win8 (yes I saw the caveats) and I'm a relative "new-bee" to the program.

I created various parts and saved them as .dft files.
Then I made an assembly drawing by drag/drop of the parts to the assy. file and I saved that off too.
Finally I modified one of the parts.

When I look with the Library tab and see the parts listed when I click on the modified part it shows the mod in the preview window at the bottom. However, when I drag/drop the modified part to the assy. drawing it always pastes the pre-mod drawing. It is as if it has cached the pre-mod info and won't accept the new info.

If I open the mod part, Ctrl-C it, go to the assy. and Ctrl-V then it gets it right.

I have tried re-saving everything, closing and re-starting SE, and it still does this. Is there some way to force SE to clear cache or ??? Is this an artifact of ST5 being used under Win8? Any ideas/suggestions appreciated.

Related question is:
Is there a way to make parts in an assembly be "links" rather than copies such that future mods to a part automatically get updated in an assembly drawing?

Please advise,
Alan D.
3 REPLIES

Re: Part Revisions don't show in assembly drawing??

Esteemed Contributor
Esteemed Contributor
You are using 2D only, so you don't have "Parts", you have drawings. This is outside typical usage of SE as it is a 3D modeler that uses drawings to document the 3D model (parts). What you are attempting to do will only work with Symbols (see Help) which have an option of being inserted "associative" to the DFT it came from.

Thanks,
Ken

Production: ST9 MP10
Testing: ST10 MP1

Re: Part Revisions don't show in assembly drawing??

N/A
Thanks Ken. I can see that Symbols will take a bit of research and learning. I was thinking of them as typographic entities, not drawings. I do understand there are not real "parts" in 2d, I was just saving of the individual drawings as parts and then including them later into a main assembly drawing. Any thoughts on the strangeness of the individual drawing not including the revisions when dragged but including them when cut/copy? That looks like kind of a bug to me.
Alan D.

Re: Part Revisions don't show in assembly drawing??

Esteemed Contributor
Esteemed Contributor
Right mouse click in the Library pane on the side in the white space, select Insert Symbol As, and then select "Link".

Thanks,
Ken

Production: ST9 MP10
Testing: ST10 MP1