ST6 SLOW RESPONSE

N/A
Ricky, I've downloaded the latest free version a couple of weeks ago. I'm finding it noticeably slower than ST5 with an unpleasant pause. This seems to be somewhat erratic but maybe more prevalent when I use a dimension command, close a BLOCK, make a GROUP, and sometimes just switching commands.
Is this what is expected?
Thanks,
Ron
5 REPLIES

Re: ST6 SLOW RESPONSE

Community Manager Community Manager
Community Manager
Ron,
I am not aware of any specific issues with performance.
Can you send to me one of the files where you see the performance problems?

Regards,
Rick B.

Re: ST6 SLOW RESPONSE

N/A
Ricky, when I first downloaded ST6, I had some strange behavior that I reported on in the thread titled: GENERAL MISBEHAVIOR BY ST6 - NEW DOWNLOAD??. Take a look at that and the subsequent update that I later added. Note the comment: “On previous versions, I would check both model files and draft files, more out of ignorance as to the difference in 2D. A little trial and error showed that if I uncheck the draft file option, the erratic but noticeable lag time stopped.” However, I later discovered that if the DRAFT file box wasn’t checked along with the MODEL file, there wasn’t a backup copy made. So now I have both checked and live with the noticeable pause whenever it does the backup action.

As of today, this is the only thing that I’m seeing in ST6 that I didn’t see in ST5; i.e., the noticeable pause that occurs when the software auto backups the open work. I also tried using the popup reminder to save but, to me, that seems even more disruptive. I timed the pauses with one file, two files, and three files open. It’s about the same length of time as if I manually hit the SAVE ALL command. Namely with:

One file open = 1 - 3 sec
2 open = 6 – 8 sec
3 open = 7 - 9 sec

The file sizes that I used in the above test are in the range of 1,700 Kb to 3,000 Kb.

Thanks,
Ron

Re: ST6 SLOW RESPONSE

Community Manager Community Manager
Community Manager
Ron,
That would make sense. As you have discovered, the timer causes a file save at the time increment specified. Any work will be stopped until the save has finished. What do you have the increment set to?

Regards,
Rick B.

Re: ST6 SLOW RESPONSE

N/A
Ricky, I have it set at 5 min intervals. I also just discovered something that I should’ve realized before, i.e., that the more layers I have visible, the larger the file size and the longer it takes to save. E.g., one the larger subject files ranges from 2300KB (w/ only AutoHide visible) to 3100KB (w/ all visible). Out of curiosity, I compared hiding cells in MS Excel and found that it doesn’t affect file size.

I can live with this, of course, but I don’t recall ST5 taking that long to save and I had the same settings

Thanks,
Ron

Re: ST6 SLOW RESPONSE

Community Manager Community Manager
Community Manager
Ron,
Go into Solid Edge options with a Draft file open. Go to the General tab. Uncheck 'Include Draft Viewer data in file'. This keeps the Save process from generating the image you see when viewing the draft file from an external process. Then click on OK.

Let me know if this helps with the save times.

Regards,
Rick B.