Reply

Setup found an existing SEProduct


Installation shield gives me the following message:
"Solid Edge 2D Drafting V19 Setup has found an existing SEProduct. Please use Add/Remove
Programs applet to uninstall Solid Edge."
When I go to Add/Remove, it does not find a SE Product. I may have tried to install
SE 2D earlier but ran into some problem (I really do not remember). I described
this to technical support phone line, and it was suggested there might be SE Fragments
in the Registry, and suggested I post the problem here. Any suggestions?
Phil
4 REPLIES

Re: Setup found an existing SEProduct


Phil,
If SE 2D Install is finding the residue of your failed install attempt, the Microsoft
Windows "Add/Remove Software" function should be able to find it as well. Have you
tried to find it and remove it?
John Stewart

"Phil Mitchell" wrote:
>
>Installation shield gives me the following message:
>"Solid Edge 2D Drafting V19 Setup has found an existing SEProduct. Please
>use Add/Remove
>Programs applet to uninstall Solid Edge."
>
>When I go to Add/Remove, it does not find a SE Product. I may have tried
>to install
>SE 2D earlier but ran into some problem (I really do not remember). I described
>this to technical support phone line, and it was suggested there might be
>SE Fragments
>in the Registry, and suggested I post the problem here. Any suggestions?
>Phil

Re: Setup found an existing SEProduct

Phil,
Are you running a copy of MasterCAM? MasterCAM has a hook that allows them
to access Solid Edge solid bodies. They have registered this under Solid
Edge instead of MasterCAM.
Regards,
Rick B.

Re: Setup found an existing SEProduct


I am having the same problem. A year or so ago, I installed the product, but eventually
decided to uninstall it. Recently I tried to re-install it, but got the "existing
SEProduct" error.
Apparently my prior uninstall was incomplete. There are still entries in the registry
that turn up when I search for "Solid Edge" and they trigger the "existing SEProduct"
error.
I have attemped to manually clean the registry, by deleting all occurances of that
phrase (and there were a lot of them!). However, then my computer wouldn't boot
properly. So, I had to restore the registry. I am guessing that I accidentally
deleted something other than a Solid Edge entry.
I just downloaded the install program again, in hopes that the install routine has
been updated. But, the problem is still there.
Is there a single registry item that I can delete, rather than repeat my prior problem?
Joe Dunfee

>"Phil Mitchell" wrote:
>>
>>Installation shield gives me the following message:
>>"Solid Edge 2D Drafting V19 Setup has found an existing SEProduct. Please
>>use Add/Remove Programs applet to uninstall Solid Edge."

Re: Setup found an existing SEProduct

Joe,
There are two places to look for registry keys.
1. HKEY_LOCAL_MACHINE - SOFTWARE - Unigraphics Solutions
Delete the 'Solid Edge' entry and the 'Solid Edge 2D Drafting' entries.
You may only see one of them.
2. HKEY_CURRENT_USER - Software - Unigraphics Solutions
Delete the 'Solid Edge' entry.
That should be all you have to delete. It should install properly now.
Regards,
Rick B.