dft file size

Valued Contributor
Valued Contributor

Hi guys

I often have a problem with the .dft file size becoming huge to the point the computer slows down.

I usually import a jpg or bmp image then create several layers over the top. A .dft file size is usually around 200-500kb and all is well. However sometimes things slow down and I realise the file size has become 20Mb for no apparent reason.

Deleting the image makes little difference.

If I watch the filesize in explorer I can see it toggle between Mb and kb as I resave.

Any ideas why this may happen? Does SE2d cache many copies of the image even if the jpg is deleted or something strange like this. I do have auto save enabled.

 

Also autosave seems to prompt me to save at the most inapproriate times, for example immediately after I have manually saved.

 

Cheers

Pete

 

2 REPLIES

Re: dft file size

Siemens Phenom Siemens Phenom
Siemens Phenom

From the GTAC Solution Center article 002-7007122:

 

Inserting picture in to draft exponentially increases the file size
Symptom
---------------
Inserting a picture or image into a draft file results in the draft file size 
being exponentially bigger than the file size of the inserted picture or 
image, sometimes by as much as 5 times bigger.
Hardware/Software Configuration
Solid Edge
Solution
This is known behaviour with Solid Edge and is currently working as 
designed.  

Currently when Draft viewer data is enabled, the image is essentially 
embedded twice into the file - once for the actual embedded Solid Edge 
draft and once for the Viewer data.  Further image files on disk are 
typically compressed.  Solid Edge currently does not compress the image 
file when it is embedded into the draft and instead embeds the uncompressed 
image file, thereby increasing the overall image size.

If the file size on disk is important to the customer then the customer can 
implement either or both of the following suggestions to decrease overall file
size on disk:

* In Sketching -> Insert -> Image use "Link to file" instead of embedding 
the image.

* In Solid Edge Options -> General uncheck "Include Draft Viewer data in 
file".

 

Re: dft file size

Valued Contributor
Valued Contributor

Hi Dave

Thanks for the response, I suspected something like this was happening.

I have turned off the draft viewer and will see what happens.

I tried to insert a jpg into the model using link to file but it doesn't appear. Can't work out what I'm doing wrong.

Embedding works fine but not link to file, any ideas what I'm missing?