trimming is very slow

N/A

Hi all,
I found out in SE 2D drafting after I draw so many line, trimming is very slow...sometimes
it causes the SE crash...
I attached a sample file..
any info how to handle this??

rgrds


Puspo
3 REPLIES

Re: trimming is very slow

N/A
Your file has the following:

467 lines @ 4 Degrees of Freedom (DOF) each = 1868 degrees of freedom
44 arcs @ 5 DOF each = 220 DOF
21 circles at 3 DOF each = 63 DOF
Total DOF in system = 2151

There are 974 constraints and 103 Dimensions in the file.

The system is solving 2151 equations each with 2151 unknowns.

The problem in this case of overuse of constraints, which is placing an
overburden on solve. To see this, turn off Maintain Relationships. Draw a
line and trim it. It will trim quickly.

My suggestion is to simplify the constraint system. Instead of trimming all
the vertical lines, which adds many connects and other constraints. Use a
combination of layers for the components you want to draw and fill them with
the background color to cover the lines of the other components. For example
use fill in the horizontal pipes to cover the vertical lines. this will
greatly reduce the number of objects and constraints. You will need to put
the vertical components on another layer so that you can turn them off to
fill the horizontal pipes. I can provide an example if needed.

This is a perfect example of something that is easy to model in 3D and
generate drawings from using 3D Solid Edge. You will not see the same
performance problems.

Regards,
Rick B.

Re: trimming is very slow

N/A

Ricky,
thnks for your response..Ihave tried to turn off maintain relationship, but the
performance still slow,
if it is ok with you, I will be very thankful if you send me the example file you
mentioned blow,

thanks,

Puspo
"Ricky Black" wrote:
>Your file has the following:
>
>
>
>467 lines @ 4 Degrees of Freedom (DOF) each = 1868 degrees of freedom
>
>44 arcs @ 5 DOF each = 220 DOF
>
>21 circles at 3 DOF each = 63 DOF
>
>Total DOF in system = 2151
>
>
>
>There are 974 constraints and 103 Dimensions in the file.
>
>
>
>The system is solving 2151 equations each with 2151 unknowns.
>
>
>
>The problem in this case of overuse of constraints, which is placing an
>overburden on solve. To see this, turn off Maintain Relationships. Draw a
>
>line and trim it. It will trim quickly.
>
>
>
>My suggestion is to simplify the constraint system. Instead of trimming all
>
>the vertical lines, which adds many connects and other constraints. Use a
>
>combination of layers for the components you want to draw and fill them with
>
>the background color to cover the lines of the other components. For example
>
>use fill in the horizontal pipes to cover the vertical lines. this will
>greatly reduce the number of objects and constraints. You will need to put
>
>the vertical components on another layer so that you can turn them off to
>
>fill the horizontal pipes. I can provide an example if needed.
>
>
>
>This is a perfect example of something that is easy to model in 3D and
>generate drawings from using 3D Solid Edge. You will not see the same
>performance problems.
>
>
>
>Regards,
>
>Rick B.
>
>

Re: trimming is very slow

N/A
Puspo,
Open the attached UseLayers.dft file. First investigate what I have done
with geometry on layers. I put the horizontal geometry on the layer named
'Horizontal'. I put the vertical geometry on the layer names 'Vertical'. I
did this to help me manage the geometry.
You need to use 'Customize Quick Access Toolbar' and add commands with 'More
Commands...'.
Change the combo box in the Customize dialog to Modify.
Add 'Bring to front', 'Send to back', 'Pull up', 'Send down'.
These commands work to change the display order of objects. Anything on top
of another object is displayed after what it is on top of.
I have created geometry to represent horizontal and vertical bars. Currently
the horizontal bars are on top of the vertocal bars. The geometry is not
trimmed. If you modify the dimensions, the horizontal bars still cover the
vertical bars.
To make the vertical bars cover the horizontal bars, it is a simple task.
Hide the horizontal layer. You will see only the geometry for the vertical
bars. Fence select all the geometry. Click on the 'Bring to front' command
that you added to the Quick Access toolbar.
Show the horizontal layer. The vertical bars will now cover the horizontal
bars.
Play with some to get the idea of how I organized the geometry.
Regards,
Rick B.