Cancel
Showing results for 
Search instead for 
Did you mean: 

Getting Over Obstacles to Solid Edge Fast Search

Siemens Valued Contributor Siemens Valued Contributor
Siemens Valued Contributor

 

For those who have installed Solid Edge ST9, you know by now that it now supports index-based search queries – a new option called Fast Search. While Fast Search is straightforward to configure, there can be obstacles (who would have thought?!) you may run into.

So let me point out the ones we are aware of, so you do not have to trip over them. Smiley Happy

 

Let us start with a fundamental pre-requisite for Solid Edge Fast Search: the Windows Search Service. Here is how Microsoft introduces it: “Windows Search is a standard component of Windows 7 … and is enabled by default. …”

What if it is not enabled? Here is obstacle #1.

While our experience shows that everyone’s PC has the Windows Search Service indeed started by default, occasionally we ran into a situation where a customer’s file server running Windows 2008 R2 didn’t have this service running. We do not recommend to have the startup type set to “Automatic (Delayed Start)”, as this can delay the indexing process unnecessarily.

Open the ‘Services’ application (click on the Windows Start button and type “services” into the search box) and make sure it is started automatically and run by the ‘Local System’ account.

Services.pngWindows' Services application

The question: ‘How does the Windows Indexer know about our Solid Edge properties?’ characterizes another vital pre-requisite for Solid Edge Fast Search. The short answer: through the installation of Solid Edge ST9.

 

Windows Explorer provides the easiest way to quickly validate this. Using the ‘Details’ view type go to any folder, right-mouse-button click on any column (i.e. ‘Name) and click the ‘More …’ button at the bottom of the menu.

Column RMB.pngWindows Explorer column RMB menu

This brings up a dialog with a long list of properties Windows knows about. Now hit the keys ‘S’ and ‘E’ on your keyboard and the selection in the list jumps to “SE Links”.

What if it doesn’t? That would make obstacle #2. (Example on the right)

Column details-correct.pngSE columns are listedColumn details-incorrect.pngSE columns are not listed

Missing the Solid Edge properties in the list are an indicator that something went amiss with registering the properties during the Solid Edge ST9 installation. A quick fix is opening the DOS terminal (click Windows Start and type “cmd” in the search window) and typing the following:

   cd "c:\Program Files\Solid Edge ST9\Program"

   regsvr32 /s SEPropertyHandler.dll

 

Subsequently restart Windows Explorer (kill the ‘explorer.exe’ process in Task Manager (RMB on the Windows task bar) and also start it again via Task Manager) and you just mastered another obstacle!

Create New Task -explorer.pngrestarting Windows Explorer

Having squared away the fundamentals, we can now move on to the Solid Edge Options dialog and specify the location(s) of our CAD files by clicking on the ‘Set Locations …’ button.

Set_Locations.pngFast Search settings in SE Options dialog

Windows ‘Indexing Options’ dialog will come up and after clicking the ‘Modify’ button one can check the desired locations.

Indexing Options - modify.pngModify indexed locations

Did you notice the different shading of the folder icon? Here is obstacle #3.

folder icon shading.pngfolder icon shading

Make sure the folder that carries your CAD files shows in bold colors. Windows indicates with the dimmed folder color, it is not allowed to index the file contents inside these folders. Therefore, if the folder you are selecting for indexing is shown in a dimmed color, close the ‘Indexing Options’ dialog and go to Windows Explorer to open the properties dialog of the folder and check the box in the ‘Advanced …’ options.

advanced folder options.pngadvanced folder options

Make sure to click ‘OK’ on the following dialog:

advanced folder options II.pngapply to all subfolders

Go back to the Solid Edges Options dialog and click the ‘Set Locations …’ button.

The folder icon shows now in bold colors and the Indexer can do its part.

 

Hope this helped …

Comments
Legend

Thanks for this information. I have a question about Fast Search on a file server.

We use a Windows Server 2008 R2 as file server and Fast Search is installed and configured. The Solid Edge file locations were added to the index and our user defined properties were added via propseed file.

If i open the indexing options and click advanced -> filetypes i can't see any entries for asm, par, psm or dft.

Is this normal?

Only Fast Search is installed on the Server, not Solid Edge (i think this isn't possible or is it?).

 

Greetings from Germany

Christian Kunkel

Siemens Valued Contributor
Yes, the Solid Edge file extensions don't appear in that list, because Solid Edge is not installed. This is normal, hence the fast search on Solid Edge custom properties should be functional nevertheless - if not, please let me know and I might be able and to help troubleshoot.

Michael
Esteemed Contributor

@Michael_RvD, has it been determined what may cause the Solid Edge properties to become unregistered even though they were recently registered?

Legend

Any suggestions for companies that do not use a MS file server?

 

It sounds like fast search and therefore any of the built in data management features are unavailable to any company using any other file serving solution than MS; SAN for example.

Siemens Phenom

@bnemec  Fast Search is based on the Windows Search Service technology so can only be used with Microsoft file servers.  There is not a solution for non-Microsoft servers.

Legend

Thank you uk_dave.  I was afraid of that, there are some good data management tools that we could really make use of. 

Siemens Valued Contributor

@KennyG the most common reasons we have been seeing are: Windows OS updates and the IT department making changes to the file server post ST9 installation (mainly changing permissions on folders containing SE files).

With regards to the latter:

  • make sure the 'SYSTEM' group has permission to your SE folders. Essentially this gives Windows access to do the indexing. On a couple of occasions IT (inadvertantly) removed those permissions and designers couldn't find things anymore ...
  • We had one case, where adding permissions to the group 'AUTHENTICATED USERS' allowed Windows to do the indexing again.
Dreamer

I have a quick question from the IT side.  In our case, SE License Manager is the only thing installed on our Windows 2008 R2 Server as far as Solid Edge is concerned.  After discussion with our CAD team it sounds like we need this search ability so I'm going through this process of setting up the indexing as described above.  The CAD computers obviously have Solid Edge (ST9) so my only confusion is whether Solid Edge has to be installed on the server in order to properly access the extra file attributes that need indexing.  Any clarification is appreciated.

Siemens Valued Contributor

Solid Edge doesn't need to be installed on the file server to to access the extra Solid Edge file attributes. Instead, only the Fast Search configuration utility needs to be installed on the file server and used to configure the custom properties to be indexed.

 

SE_install_-_fast_search.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To ensure custom properties are consistent, it is recommended to have the propseed.txt and template files in a shared location, that can be accessed by the Fast Search configuration utility on the server as well as the Fast Search configuration (SE Options) on every CAD computer.

Enthusiast
 

Hello
I would like to know how is it with the SYSTEM Group, Michael_RvD says, that this group needs permissions to the folder which needs to be indexed, but I have read:


If the directory gives access to Administrators, then it is not necessary to give access to SYSTEM. Any access token including SYSTEM will also have Administrators.

Could somebody verify if is it true?
We have virtualized WindowsServer 2008 R2 and there are all our DATA. On this server is Installed SE FastSearch utility.
I have made Indexing on whole volume where are the CAD files, but steel the clients are not able use the FastSearch in SolidEdge .

Enthusiast

I will try it in experimental enviroment.

Siemens Phenom

@ZAJDAN did you install the Microsoft Windows Search Service on the server?


Did you configure the clients and add the indexed server folders to the client's Solid Edge settings?

Legend

@ZAJDAN you said the windows server is hosted on a virtual machine?  Does that windows server OS see the your files as being on a local disk?  As far as I know microsoft windows search service only works on files that are on local file systems.

Enthusiast

My use case and the Result:

 

1) Windows server 2008 R2 is virtualized and extended HDD is attached as Solid drive, so the system see the disk as physical...this is not the problem.

2) Indexing servise(Windows search) is installed and works.

3) SolidEdge FastSearch utility is installed on the server.

 

but what is really necessary is the FolderPermissions for the SystemGroup, because really the Administrator is not enaugh!

Now, when I added also the SystemGroup into the list of permission ,so it works nicely.

 

Regards Zdenek Chladek

Siemens Experimenter

We recommend the locally defined "System" account run the Windows Search service as this is built in and running when the server is simply booted up. If you use "Administrator" or another user account then you need to define if the account is local or from the domain controller and maintain that the password is specified and correct should that password change.

 

Either way, System or a specified user account requires the objects to be accessed must offer enough permissions to perform the required task. By default an attached volume offers System full access which is more than enough. Reducing this could have impact somewhere else such as back up and restore. 

 

Is there a reason that you would like Window Search service to use Administrator as opposed to System?

Enthusiast

@
Please read what I wrote. I speak about folder permissions not about account under which user runs the Search service.

Legend

@ZAJDAN I believe that was Greg's point.  The files need to offer correct permissions to the user running the program that is trying to access the files.  So if you say that the default permissions granted to the "System" user is not working, but adding Admin permissions does work we must assume that you are running the indexing service as Admin user and not System.

  That is some what like running explorer (file explorer) as a different person, only to realize you cannot access your user folders so you extend file permissions of your user folder to that other person.

  Greg is kind enough to offer the suggestion that it is highly advisable to run the indexing service as System, not as Admin.  Then the default file permissions you're talking about granted to the "System" user will work fine.

 

...unless you have come across a situation where that is not true.  If that is the case, he's asking about it.

Siemens Experimenter

@ZAJDAN

I work in Solid Edge development as Senior Applications Engineer for Document Management solutions, and I would like to answer your question. However, I am not completely clear on what you are looking for. Administrator is not a permission it is a user account that Microsoft delivers on install and advises that you eliminate as soon as possible. Administrators also is not a permission, it is a user group that users can be added to that have a default level of permissions. That default level of permissions are not on the group but objects and policies providing permissions to members of the Administrator group.

 

So whether you run as System, Administrator, or some user that was added to the Administrators account; it comes down to does the search service have permissions to pull properties and write them to the index while operating on behalf of that user. Therefore I assume your question is; "what permissions are required for the search service to index your files"?

 

1st of all, I am not really sure that you can use a user other than "System" as there are 2 parts to this. Ability to read the properties and ability to write the results in to the index DB. The 2nd being the key. Therefore I would advise that you stick with the System account and not use Administrator or any other user account unless there is a specific need.

 

2nd, if proceeding with System, perhaps there is a security concern that damage could occur to your files through the System account. In which case you can experiment by removing "Full Control" then apply permissions until you have satisfactory results. I suspect there is no need for Modify or Write permissions to index files. Although I have not actually tested this.

 

There is more to it than just this as you need to consider permission inheritance in NTFS permissions, but we can discuss that if this is still an issue.

Enthusiast

Ok, I will try to explain again, because You probably did not understand me. The service Windows Search runs under LocalSystem from the begining, it should be ok...agree?
services_WindowsSearch.png

In Folder Security/Permission, there was the problem. Before I did not have the SYSTEM group in the list of Security, only users and Administrator. Fast Search did not work.
After that I added the SYSTEM group in the list, as You can see on the picture below, all work fine. But this I already wrote in previous comment and it was also the my first question.
Permissions.png

Please, if Iam wrong let me know.

Regards Zdenek Chladek