Showing results for 
Search instead for 
Did you mean: 

Translating Solid Edge Files from the Command Line

Siemens Phenom Siemens Phenom
Siemens Phenom

In this recent Solid Edge Community forum post, there was discussion and mention of a Solid Edge command line translation capability. In this article we review this little known Solid Edge command line translator tool and its options available.

Under “C:\Program Files\Solid Edge ST8\Program” exists the file “SolidEdgeTranslationServices.exe”: 




This is a command line tool that was originally designed as a utility for translating Solid Edge files to third party file formats for use with PLM systems [Teamcenter cough, cough Robot wink]However, there is nothing preventing us from using this utility outside of PLM Robot Very HappyUnfortunately, given the intent of the tool, there is no readily available documentation on this tool in the Solid Edge help system:




If you attempt to run the tool from the command line without any options you will receive an error and no prompting of arguments is provided. If you attempt to run the tool with typical help arguments, again you will receive no prompting or help on what arguments are needed or available:




Thankfully those helpful folks at GTAC Robot winkhave already documented the command line options for you:




So for those who don't access the GTAC online resources (why aren't you?), what are the arguments available for SolidEdgeTranslationServices.exe?

Here are the command line switches available for SolidEdgeTranslationServices.exe:


  • –i = input file
  • –o = output file
  • –t = what format to convert to (e.g. pdf, tif, dwg, jt, bmp, igs, etc.)
  • –w = width 
  • –h = height
  • –r = resolution (100, 200, 300, 600, 1200)
  • –c = colour depth (1, 8, 24 where 1=MONOCHROME, 8=256 COLORS, 24=TRUE COLOR)
  • –v = visibility of Solid Edge (TRUE, FALSE)
  • –q = image quality (LOW, MEDIUM, HIGH)
  • –m = multiple sheets (TRUE, FALSE)


So how to actually use the command line translator? At a minimum you must supply the input file, “-i”, output file, “-o”, and the type of file to convert to, “-t” e.g.


SolidEdgeTranslationServices.exe -i="C:\Program Files\Solid Edge ST8\Training\stddb3d.dft" -o=C:\Temp\test.pdf -t=pdf


NOTE: if your file path names contain spaces you will need to surround the paths with quotes " ".




Voilà, a converted PDF from the Solid Edge draft -- all from the command line:




So what file types for the -t parameter can SolidEdgeTranslationServices.exe actually convert to?


Here is the list of supported conversion formats and the file type to specify for the “-t” parameter:


Solid Edge 2D Draft File Types


  • Adobe Acrobat (pdf)
  • AutoCAD (dwg)
  • AutoCAD (dxf)
  • JPEG Image (jpg)
  • IGES (igs)
  • MicroStation (dgn)
  • TIFF Image (tif)
  • Windows Bitmap (bmp)
  • Windows Enhanced Metafile (emf)


Solid Edge 3D Model File Types


  • ACIS (sat)
  • Adobe Acrobat [2D & 3D] (pdf)
  • CATIA V4 (model)
  • IGES (igs)
  • JPEG (jpg)
  • JT (jt)
  • Parasolid (x_t)
  • STEP (.stp)
  • STL (stl)
  • TIFF Image (tif)
  • VRML (wrl)
  • Windows Bitmap (bmp)
  • XGL (xgl)
  • XML (plmxml)

As you can see, there is quite an extensive list of file formats supported by the Solid Edge command line translator.


So what do all of the command line options do? Obviously not all command line options would be appropriate for all file types. For example, you would not specify a width or height for a STEP file. To be honest there are too many different file types and options appropriate for each of the file types to even begin to individually and fully document them all here.


If you are not sure what options would be appropriate for your desired file translation, simply open up Solid Edge, manually create a file translation, and pay attention to the options available to you when manually creating the translation from within Solid Edge:




So in the above example we are reviewing the Save As Image to Windows Bitmap options available. From this screenshot, when compared to the command line line options available, we can easily deduce that the following would be appropriate options for the command line, as each option is selectable and settable within Solid Edge:


  • –w = width 
  • –h = height
  • –r = resolution (100, 200, 300, 600, 1200)
  • –c = colour depth (1, 8, 24 where 1=MONOCHROME, 8=256 COLORS, 24=TRUE COLOR)


However, the option “JPEG Image Quality” is not selectable for a Windows Bitmap so the following command line option would *not* be appropriate:


  • –q = image quality (LOW, MEDIUM, HIGH)


NOTE: In order to generate 3D PDF files with this utility you must first enable 3D PDF in the “C:\Program Files\Solid Edge ST8\Program\Define_SolidEdge_Properties_ForWorkflow_ToSync.ini” file by editing the file and setting “Export 3D PDF from part or Assembly=1”. If this option does not exist in the file, then you can manually edit and add the option at the end of the file. Without this setting existing or being set equal to 1, PDF files generated from Solid Edge models will be 2D PDFs:



So, now that you know there is a Solid Edge command line translator available, what can you do with such knowledge? Well, you could create a Windows scheduled task to automate the conversion of your Solid Edge draft files to PDF files overnight. Or you could create a utility to allow conversion of Solid Edge files directly from within Windows Explorer. Or...




Happy translating :-)


Solution Partner Valued Contributor

This is nice! Is there a similar tool to batch convert a set of files from STEP/IGES/Inventor/SW/etc to Solid Edge format?

Valued Contributor

@Cadflow Just seen this, have you tried the 'Batch' tool in the program folder?  C:\Program Files\Solid Edge ST8\Custom\Batch\Bin




@uk_dave Thanks for the post, it helps a lot.

I am currently trying to do batch files to translate dft files to jpg as it is an easy format to manage on a workshop floor, but when I run the batch it returns a failure message of Solid Edge, windows then tries to find a solution to the issue, I need to tick manually the "Cancel" button box for the program to carry on its execution.

With a closer look, this seems to happen only with multiple sheet drawings.

I tried to play with the -m options stating "-m=false" or "-m=true" but the outcome is the same: Solid Edge working on background crashes, the file is translated and the sheet converted to jpeg is the last one of the dft file.

Do you know a way to get only the first sheet of the dft document to be translated?


Thank you again and to the guys of the GTAC.

Valued Contributor
@Solinpro jpeg?  Sorry but why not use PDF then at least it remains a vector based format and is scalable.



@Guy_H77 we already use pdf. But in order to get flexibility scrolling into a big list of drawings, you need too many clicks to visualize them. If you use jpg or tif, with the windows picture reader, you can easily scroll up and down the files and at the same tiem visualize them. It is not so much a problem of getting precision on the drawings, it is more related to giving ways and means to people on the shop floor to travel easily through all the drawings of a project.

If there are other ways to get around the problem, any idea is much appreciated.

Siemens Phenom

@Solinpro I have tested this on ST9 MP5 and the -m switch is *not* generating multiple JPEG images as expected.  Currently the tool is only creating a JPEG file for whatever draft sheet is currently active when the file is opened.  The -m switch does however appear to be working as expected with DXF files.  


Also, I am not getting any crashes.


I can generate a PR for you on this issue.  Please PM your sold-to id.


I noticed it's re-sizing the sheet size. All my documents are setup as 17x11 (ANSI B or B Wide) and it's changing them to 11x8.5. Is there a way to define 11x17 landscape page setup if it cannot use the settings from the document? This happens in the batch GUI utility as well, that is, it's not working and is re-sizing documents to 11x8.5. I have defined the page setup in the Solid Edge Velocity PS Printer 2.0, but that doesn't seem to do anything.




@uk_dave It was only converting the first (i.e. active) sheet for me as well to PDF, so I moved my -m=true switch to earlier in the line, right after my -o= switch and changed the case from lowercase to uppercase (so -m=TRUE) and now it's converting the inactive sheets as well to PDF, so perhaps it will do it for your jpg conversion as well.  These two changes, in my opinion, normally shouldn't matter, but in this instance, it did.

Siemens Phenom

@nate456 There was a change in how the PDF files are now generated by Solid Edge.  This means that for the command line translator, the -m switch no longer works with PDF files.


The creation of single or multi-sheet PDF files is now solely dependent on the Save As PDF settings from within Solid Edge.  To change the settings start Solid Edge and open a new draft file. Select Save As and set the file type to PDF, then select the "Options" button. Set the options you want to use for the PDF files for the command line translator, then finish saving the file. The options you chose are then stored in the registry and will be used the next time SolidEdgeTranslationServices.exe generates a PDF file.  You could capture what those registry settings are and combine them with your script to be set before calling the command line.


Ah, by happenstance I did go into Solid Edge and do a Save As before trying the -m switch again, so I guess that's what resolved it, not the placement of it on the line.

Siemens Phenom

@nate456 our posts crossed.  I think your changing of the switch order is a coincidence and what has happened is that your PDF settings in the registry have now been picked up.


Try changing the switch order back again -- does it now stop working?


@uk_dave You are correct, switch order does not matter. I moved it back to how I had it and it's now generating all sheets with the command line; I was just playing around with so many settings I didn't think that another one was the resolution.


I'm still having the paper size issue though. In Solid Edge in Sheet Setup the documents are set to 17x11 and if I do a save as > pdf, they save and look correctly. If I run the same documents through the command line utility, it changes the paper to 11x8.5.


I've gone into the Printing Preferences for the Solid Edge Velocity PS Printer 2.0 printer (if I watch the printer queue of this printer, I see jobs coming through while the command line is running)  and changed the paper size to ANSI B along with the Printing Defaults under Advanced (same settings, Landscape on Layout tab and ANSI B under Advanced Options), but it's still changing them to 11x8.5.


I'm not sure where it's picking this setting up from or how to override it.




Siemens Phenom

@Solinpro I never heard back from you but went ahead and pushed your JPEG issue through internally.  I can now report that with ST10 we should support the -m=TRUE switch for JPEG and all of the image formats.


@nate456 I also pushed on the PDF and again, with ST10, the PDF creation will also support the -m switch, regardless of the user's PDF print settings.


Any demonstration video?