If you're still on MP0 or haven't yet installed ST6, you don't have to apply each patch, you can just apply the latest one. The download for ST6 will ...