Reply

Behavior XP/64 and Win7/64, documents.open

[ Edited ]

 

Hi

 

I've created a programm where opens files (list of files in textfile) to get several information (attributes, structure, links and  so on). The programm runs in a batch mode.

 

The program is running on two different machines (XP64 and Win7/64). The behavior is complete different. Where the program is running at XP64 without any significant breaks in cpu-consumption, the win7 machine shows very long cpu idle time specially when it opens drawings. Ín the configuration of SolidEdge (ST4) I cannot see any differences where could influence the program.

The systems are different in cpu (i5 and i7), the program is running faster at the i7 processor, no question, but these big cpu-idle gaps at the i5/W7 machine (30secs and more) is not seen at the i7/XP cpu

 

I guess the time gets lost during the open sequence. I use the following start options to open the documents:

 

objApp.Visible = False

objApp.DisplayAlert = False

objApp.Interactive= False

objApp.ScreenUpdating= False

 

objApp.Documents.Open(sFileName)

 

 

I'm looking also for the option to set "inactivate drawings for review" because I assume I drawing update would be disabled. Is there a way to set this option programmaticaly?

 

Any ideas?

 

Regards and many thanks for support

romu

 

 

Posted by: Rolf Murer
Post date: 1/8/2012 10:56:54 PM

6 REPLIES

RE: Behavior XP/64 and Win7/64, documents.open

[ Edited ]

for a session of Solid Edge you must set:

 

objApp.SetGlobalParameter(SolidEdgeFramework.ApplicationGlobalConstants.seApplicationGlobalSessionDraftOpenInactive, True)

 

Regards

JR

 

Posted by: JR
Post date: 1/9/2012 1:16:34 AM

RE: Behavior XP/64 and Win7/64, documents.open

[ Edited ]

 

 

 

Hi JR

Thanks for the reply

Those paramteres I did'nt know until know. Therefore it will be helpfull. But it didn't solve my problem.

Now I found the following:

- if I open the drawing with ST4 interactiv (file is original ST2) where my programm stocks, also ST4 interactiv waits during the open process. It is waiting for about 30 seconds and no activities in cpu nor network during this time.

- I saved the file with ST4 to an other location, the open process is quick as predicted (1sec)

- If I start ST4, open a solidedge-files and let the program stay --> 25% cpu for the Edge.exe prcess (no other activities at all, I even swithed off the antivirus programm and firewall). As

 

So far, I guess now, this is not a programming problem, it is a basic solidedge problem.

 

I now found with process monitoring, that solidedge ist looking for a registry entry "HKLM\SOFTWARE\Unigraphics Solutions\Solid Edge\Version 104\CLSID\{72108BA6-F824-11D2-A24C-00C04F79B2AF}\InProcServer32" all the time. I started to create the key "inProcServer32" manually, edge found now the key, but then it is looking for further keys. So manually create the missing registry entries will not be the solution.

 

It could be that I have more than one problem (number one= open the files, number two= the beahvior with the cpu load)

 

 

 

Any idea what I could do further?

 

 

Regards

romu

 

 

 

 

 

Posted by: Rolf Murer
Post date: 1/9/2012 5:24:19 AM

RE: Behavior XP/64 and Win7/64, documents.open

[ Edited ]

 

 

Hi

 

I found a workaround for the high cpu load: Starting SolidEdge as Admin helps. If I keep documents opened, no high cpu load occurs anymore.

 

I saw the Edge.exe (running as normal user) process was trying to access some regsitry keys, they were not available. It accessed those keys all the time and this was the cpu consumption without any user actions. Why it is ike that? I don't know. What I have to do, to get solidedge running as "normal" user without this problem: I don't know.

 

Regards

romu

 

 

Posted by: Rolf Murer
Post date: 1/9/2012 11:40:46 PM

RE: Behavior XP/64 and Win7/64, documents.open

[ Edited ]

Hi romu,

 

only some ideas what more to check:

 

- Is the negative behaviour depending on the user account used?

- Did you try with a newly created test user account not having Administrator privileges?

- Might it be related to user specific (my be broken) addin settings?

 

 

Posted by: Wolfgang Kunert
Post date: 1/10/2012 12:53:22 AM

RE: Behavior XP/64 and Win7/64, documents.open

[ Edited ]

the same here! please use "filemon" from sysinternals to see whats going on:

I installed it with my user with admin privilegs, and now users have high load because SE tries to go into my folder:

now we got 16% load, just with a plain opened SE ;(

 

14 15:52:40 Edge.exe:5856 OPEN C:\Dokumente und Einstellungen\tk032\Anwendungsdaten\Unigraphics Solutions\Solid Edge\Insight\Cookies(tk073)\translog.xml ACCESS DENIED LINCK-HVT\tk073

15 15:52:40 Edge.exe:5856 CREATE C:\Dokumente und Einstellungen\tk032\Anwendungsdaten\Unigraphics Solutions\Solid Edge\Insight\Cookies(tk073)\translog.xml ACCESS DENIED LINCK-HVT\tk073

16 15:52:40 Edge.exe:5856 OPEN C:\Dokumente und Einstellungen\tk032\Anwendungsdaten\Unigraphics Solutions\Solid Edge\Insight\Cookies(tk073)\ SUCCESS Options: Open Directory Access: 00100000

 

Posted by: Linus Hechinger
Post date: 1/10/2012 3:03:57 AM

RE: Behavior XP/64 and Win7/64, documents.open

[ Edited ]

^^ so looked in the registy and found

"LocalWorkingFolder"="C:\\Dokumente und Einstellungen\\tk032\\Anwendungsdaten\\Unigraphics Solutions\\Solid Edge\\Insight"

just deleted it

it is rebuild on SE start with the users path,

^^ don't know why it is wrong ?

 

Posted by: Linus Hechinger
Post date: 1/10/2012 3:10:34 AM