Problem with missing reference and finding occurence

 

hi,

i'm just starting programming vb .net, i'm working on a export macro.

i made a .exe that connects to solidedge ST.

i'm using vs2008.

 

the problem is that i made this program last week and it was working fine.

but when i opened it today to make a few changes it was missing a reference to

Interop.SolidEdgeDraft so i re-added the reference (bin\debug\..) . it seems to be fixed

but it won't find the running solidedge application(Marshal.GetActiveObject("SolidEdge.Application")

 

i have no idea what 1 made the reference gone missing and 2 why it can't find the running app..

i was hoping some could explane this to me, so i might learnSmiley Happy

 

 

thnx in advance,

ErWo

 

Posted by: Wouter Sloof
Post date: 6/3/2009 11:24:28 PM

1 REPLY

RE: Problem with missing reference and finding occurence

Hi,

 

Is noone experiencing difficulties with the combination Visual Studio 2008 en Solid Edge (ST)?

 

My project was working fine, and suddenly the references to the Solid Edge library were missing. Trying to redefine the refereces didn’t work and the project seemed to be corrupt in some way. Then I tried it on another computer, the project seemed to be working again, but after some time the problem reoccurred.

 

If you need more info, please let me know, because I really want to fix this problem.

 

I hope someone has got a solution!.

 

Thnx in advance!

 

ErWo

 

 

Posted by: Wouter Sloof
Post date: 6/9/2009 7:54:50 PM