Cancel
Showing results for 
Search instead for 
Did you mean: 

Solid Edge ST10 hangs with add in

Experimenter
Experimenter

Hi All, I would like your help.

 

While trying to start Solid Edge (SolidEdgeUtils.Connect), I notice that if I have the PDM integration add-in "connected", Solid Edge will start (edge.exe on process monitor) but then it will try to start design manager (desmgr.exe) due to the PDM integration add-in and fails.

 

If I disconnect manually the add-in and perform the SolidEdgeutils.connect, I don't have that problem.

 

What I'm trying to accomplish at this moment is start Solid Edge, disconnect the add-ins hoping to have a successful startup and then connect the add-ins.

 

SolidEdgeFramework.Application seApp = null;
SolidEdgeFramework.AddIns addins = null;

seApp = SolidEdgeCommunity.SolidEdgeUtils.Connect(true);

seApp.Visible = true;
seApp.WindowState = 1;// 2=Make window full screen, 1=minimize, 0=window mode
seApp.DisplayAlerts = true;
seApp.ScreenUpdating = true;

seApp.DoIdle();

//addins = seApp.AddIns;

//foreach (SolidEdgeFramework.AddIn addin in addins)
//{
// addin.Connect = false;
//}

seApp.DoIdle();

//addins = seApp.AddIns;

//foreach (SolidEdgeFramework.AddIn addin in addins)
//{
// addin.Connect = true;
//}

 

Thank you for your help!

2 REPLIES 2
Highlighted

Re: Solid Edge ST10 hangs with add in

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hi @DMX,

 

I think the only way to accomplish this is to change the user registry accordingly before connecting to Solid Edge via its API.

 

The registry paths involved (shown for V2019, but similar also for ST10):

 

Computer\HKEY_CURRENT_USER\Software\Siemens\Solid Edge\Version 219\AddIns\

 

I.e. the add-in "Solid Edge 2019 Illustrations Exporter" has the registry path:

 

Computer\HKEY_CURRENT_USER\Software\Siemens\Solid Edge\Version 219\AddIns\{184DF0D9-1A4F-49BF-A5F1-9A91A6881557}

 

To turn on/off an add-in the key AutoConnect can be set to 1 or 0

 

 

 

Kind regards,
Wolfgang Kunert - www.wksyspro.de

Re: Solid Edge ST10 hangs with add in

Experimenter
Experimenter

Hi @wku 

 

Modifying the Registry do the trick, Thanks. I also found out that I can get the same result without modifying the Registry with regedit by unchecking manually the Addins from within Solid Edge (Setting --> Addins) and close the program (this will modify the registry), with this change Solid Edge won't do the call to the Addin and when I run SolidEdgeUtils.Start or Connect, it opens without issues.

 

Kind Regards

DMX