SolidEdge - Vista - Visual Studio 2005 Debugging

 

I have been forced up to a new development machine running Vista and am getting more and more frustrated with how poor the operating system and it's interaction / ability to run naive (Microsoft) windows applications is...

I am using Visual Studio 2005 (with the latest service packs and the special vista service packs designed to make it work a little better - still doesn't work very well I should add!) and when I start debugging my addin with solidedge, the edge.exe process starts, gets to about 90mb of memory use then just stops. - Nothing further happens with it.

Running solidedge on its own works fine.

Does anyone else have any experience running visual studio 2005 on vista with solidedge (19 in this instance) that they could share any tips with?

Thanks!

Chris.

 

Posted by: chris mann
Post date: 8/27/2008 1:02:08 AM

3 REPLIES

RE: SolidEdge - Vista - Visual Studio 2005 Debugging

Hi,

 

We have had problems debugging our app calling the Solid Edge API with Visual Studio 2005 on Vista. The cause was that our app, when debugging from VS, was running with administrator rights. The Solid Edge instance only had normal user rights. It seems Vista won't let processes with different User Account Control levels talk to each other. It worked fine if Solid Edge was 'run as administrator'.

 

I don't know whether this is relevant to your problem though!

 

Andy

http://www.partbrowser.com/

 

Posted by: Andrew Sherlock
Post date: 8/27/2008 4:05:46 AM

RE: SolidEdge - Vista - Visual Studio 2005 Debugging

Andy,

 

Thanks for the suggestion. - I had tried it by running visual studio "as administrator" but this still caused it to hang. Not starting as administrator caused our commands to register the built dll at the end to fail (presumably due to Vista's wonderfull security enhancements....)

 

A bit more testing shows that enabling the administrator OS account, logging in as that account, rebuilding the project and running in debug mode allows it to work correctly. - Confirms to me that it must be some security permission or setting somewhere that is preventing it. - But whether it is a registry setting, file system area or something else will probably take me forever to track down.

 

So, what I've decided to do is (rather drastic, but now's the best time to do it) reset my machine back to a clean vista image, enable the admin account, rename it to my normal everyday user name, reinstall my development environment and (hopefully) work happily from there on! - I guess I am lucky to have a new machine without too much history on it and a working environment where I'm not locked into certain configurations...

 

Thanks,

Chris.

 

Posted by: chris mann
Post date: 8/27/2008 4:13:44 AM

RE: SolidEdge - Vista - Visual Studio 2005 Debugging

Hi guys,

 

I've had similar problems, I got so board of it I turned off UAC and it works as expected now.

OK so you dont have all of that extra protection that UAC gives you but things will conistently work as expected.

 

Control Panel>User Accounts>Turn User Account Control on or off

 

James

 

Posted by: James Singleton
Post date: 9/9/2008 11:58:04 PM