Reply
Solved! Go to solution

Apply status to linked documents ST9 - Design Manager

We are upgrading to ST9 and I’m setting up Options.xml with the SEadmin tool.

Where do I change so I can overwrite/change “Apply status to linked documents” in Life Cycle Assistant?

 

status.jpg

11 REPLIES

Re: Apply status to linked documents ST9 - Design Manager

I think it's this:

allowunreleasedlinks.JPG

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: Apply status to linked documents ST9 - Design Manager

No that did not work for me, the button is still greyed out.

Re: Apply status to linked documents ST9 - Design Manager

[ Edited ]

You exited and restarted SE or DM?

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: Apply status to linked documents ST9 - Design Manager

Yes I did, and also pressed update under DM->Options->File locations->SEadmin

 

Re: Apply status to linked documents ST9 - Design Manager

Hmm, I'm stumped. I had the exact same problem several weeks ago and that was the fix. The only thing I wonder is that perhaps the options.xml file pointed to or modified is not the file you think it is.

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: Apply status to linked documents ST9 - Design Manager

I see a PR#7870628 on this for ST9 MP2 with no workaround mentioned.

LMGi
www.TLMGi.com

Re: Apply status to linked documents ST9 - Design Manager

That's my PR, but that's where the solution I mentioned came from. I didn't see the problems that the GTAC person wrote up so I was a little surprised when reading it. (detailed below)

But based upon that I suggest trying the different combinations here to see if it changes the switch as desired.

Description: The option "Allow unreleased links" in the options.xml file is not working correctly in ST9. 

In the options file when Allow Override is set to Yes and the Value is set to True the LCA allows override and the apply status option is activated. This appears to be working correctly.

In the options file when Allow Override is set to Yes and the Value is set to False the LCA allows override and the apply status option is activated. The apply status option should not be enabled.

In the options file when Allow Override is set to No and the Value is set to True the LCA allows override and the apply status option is activated. The end user should not be able to change the apply status option.

In the options file when Allow Override is set to No and the Value is set to False the LCA does not allow override and the apply status is activated. The end user cannot override, which is correct, but the apply status is activated when it should not be.

Steps to Reproduce: Set the "Allow unreleased links" option in the options.xml file to the settings above then observe the Apply Status option in LCA. 

 

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: Apply status to linked documents ST9 - Design Manager

More on this: The PR did not specify a how or when to the resolution of the problem that the GTAC tech pointed out for some reason. I just responded to the last email on this PR addressing that very question and am waiting for an answer. In the meantime it might be useful to open another IR to GTAC about this. Even though the setting worked as expected for me maybe the poster is experiencing the same problem GTAC ran into.

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200
Solution
Solution
Accepted by topic author stefan_s
‎12-08-2016 02:29 AM

Re: Apply status to linked documents ST9 - Design Manager

@stefan_sOK. Got an answer from GTAC. The fix is in for ST10. He agreed with me that you might try the various combinations to see if you can get it to work. He also suggested you call GTAC about it.

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200