Cancel
Showing results for 
Search instead for 
Did you mean: 

Assemblies opening with top level "shown" but all children hidden (or check box cleared)

Legend
Legend

Just wondering if anyone else is experiencing this.  Not always, but sometimes when I open an assembly none of the parts are shown.  Seems to have started when I installed MP9 (on ST9) but not 100%.  Doesn't matter how it was last saved, happening both on files that only I've been working on and when I open from production.  Non managed environment.

 

Thanks.

 

 


Those who know me question the assigned user rank.
3 REPLIES

Re: Assemblies opening with top level "shown" but all children hidden (or check box cleare

Siemens Phenom Siemens Phenom
Siemens Phenom

On your  "Assembly Save As" options for one of the Assembly size types e.g. small, large, etc.  did you change your "Hide all components" default from Yes to defaults to No?

 

You can quickly reset your "Assembly Save As" options by closing Solid Edge and removing the following registry key:

 

HKEY_CURRENT_USER\Software\Unigraphics Solutions\Solid Edge\Version xxx\PrefSets\FileOpen

 

Failing that  you can always try a complete Solid Edge user preference reset.

Re: Assemblies opening with top level "shown" but all children hidden (or check box cleare

Legend
Legend

Thank you @uk_dave, and not that I recall.   They are all set as "no".  I'm looking at the open as, is there another setting for save as? I did hit the reset button on this tab and so far they are opening shown as they should be.

 

I struggle to know which are document settings and which are application settings.I get confused with this setting dialog, am I changing the behavior of the assembly that is currently open where ever it is opened or am I changing how assemblies are opened on this computer, (or where ever I log on with my user settings)?  If it's the former then the three different sizes don't make sense as I'm configuring how this assembly opens and should be aware of how big it is.  If it's the latter then why the heck is this settings tab only available when an assembly is open and in focus?  

 

 

image.png


Those who know me question the assigned user rank.

Re: Assemblies opening with top level "shown" but all children hidden (or check box cleare

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@bnemec  The Assembly Open As dialog is a global setting.  Each assembly is analysed for part count as it is opened to see what rule it fits into.  The rule that fits is then applied.



Ken
Production: ST10 MP9, Testing: SE 2019
http://Grundey.blogspot.com