Reply

Assembly configurations for subassembly have taken over in main assembly

Hello,

 

I have an assembly where I have created multiple configurations.  Today, I picked one of the major subassemblies so I could chose a configuration for it.  Now, I cannot pick any of the configurations for the main assembly.  This is a big problem.  I'm running ST7.

 

Kyle

Kyle Joiner
IPA LLC
ST9 MP1
8 REPLIES

Re: Assembly configurations for subassembly have taken over in main assembly

Hi Kyle,

 

So do they still list in the assembly Display Configurations?.....but when selecting them, nothing happpens??

Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST10 [MP0] Classic [x2 seats]
Windows 10

Re: Assembly configurations for subassembly have taken over in main assembly

When I open the configuration dialogue box, the .cfg file is for the correct main assembly model, but the configurations shown belong to a subassembly(Door Bar).  I may just have to delete the configuration file for the main assembly and start over.  I use configurations extensively to create assembly drawings and fortunately, I have not started assembly drawings for this machine.  I do use the Door Bar subassembly in another variant of this product.  I just completed a series of assembly drawings for that machine.  If the door bar assembly configurations overwrite the configurations for that machine, I'll have a real problem on my hands.  I have attached a capture from the model.  You can see that the .cfg file is for the main assembly, but all of the configurations listed are for the door bar and include timing belt designs and other components that should be down a couple of levels.

 

Kyle

 

Kyle Joiner
IPA LLC
ST9 MP1

Re: Assembly configurations for subassembly have taken over in main assembly

Hello,

 

Apprently SE has done something similar to my other model.  Luckily, the configurations I used for the upper level assembly drawings still exist.  I don't understand how a subassembly's configurations started showing up in an upper level assembly.

 

Could something be happening where I pick the subassembly and choose its configurations while in the upper assembly and it overwrites them?

 

Kyle

Kyle Joiner
IPA LLC
ST9 MP1

Re: Assembly configurations for subassembly have taken over in main assembly

I copied the assembly configuration file to another location.  Then I deleted the .cfg file so SE could create a new one.  I then opened the assembly and create a a single configuration.  Then I did these steps:

 

1.  Clicked on the door bar assembly and picked one of its configurations.  I then selected the main assembly and tried to find the new configuration I created moments before.  The door bars configurations are all I saw.

 

2.  I then selected another subassembly and picked one of its configurations.  Same result.

 

It seems that once I pick a subassembly and choose one of its configurations, gets stuck with tha list. Those configurations are stuck in the list.

 

I could very easily illustrate this with a video, but we are in the patent process right now.

 

Am I missing a check box or some option?

Kyle Joiner
IPA LLC
ST9 MP1

Re: Assembly configurations for subassembly have taken over in main assembly

This is happening with other assemblies.  Is there some option I'm missing that was added in ST7?  I never had this problem before.

 

Kyle

Kyle Joiner
IPA LLC
ST9 MP1

Re: Assembly configurations for subassembly have taken over in main assembly

[ Edited ]

I believe someone else had this issue and it resulted in a PR.

 

Here is the other thread...

http://community.plm.automation.siemens.com/t5/Solid-Edge-Forum/Assembly-Configuration-majorly-screw...

 


Thanks,
Ken

Production: ST9 MP7
Testing: ST10

Re: Assembly configurations for subassembly have taken over in main assembly

Hi Ken,

 

Thanks for the link.  That is the same problem I'm having.  I'm running a Quadro 2000 card on my system.

 

Kyle

Kyle Joiner
IPA LLC
ST9 MP1

Re: Assembly configurations for subassembly have taken over in main assembly

See the link to the thread that Ken posted above.  I attached a link in that post with a Jing video to illustrate the issue.  This problem will wreck my ability to create assembly drawings and control my models.

 

Kyle

Kyle Joiner
IPA LLC
ST9 MP1