Showing results for 
Search instead for 
Did you mean: 

Assembly onto a ring


I am pretty new to solid edge and cad in general and am trying to assemble a part for a school project. I am making a ceiling fan and currently I'm trying to attach the fan blade arms to a ring. Ive attached a picture to show where I am right now.


I can't seem to attach all 5 of the arms to the center ring correctly. I can not fully position them at equal distances around the ring. I will mate them, them axial align them and lock the rotation and they just attach to whatever point they want.


To solve this, I tried to use pins and holes and use the insert command, but that command won't work with an axial align to the center ring. So the arms are properly centered around the ring, but not in an orthaoganal orientation.


What procedure should I use to align and fully position these arms to the center ring? Theres going to be 5 total.


Re: Assembly onto a ring

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi there @Stueck9356,


I would use a Mate + Axial + Planar [can temporarily expose part planes during placement]......then using a sketch, make a circular pattern sketch, placed concentric to the ring, exit the sketch, use the pattern command [follow the prompt's at the bottom of the screen] to place the pattern using the previous sketch, which will drive the path & count of all parts selected to be included.  HTH.

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge 2019 [MP8] Classic [x3 Seats - Cloud Enabled]
Windows 10 - Quadro P2000

Re: Assembly onto a ring


Awesome! So I have all five of the arms properly placed. Now adding a rotational motor to the center ring, and running it in animation, I notice only the initially-placed arm is actually connected and rotating with the ring. The patterned arms are stationary.

Re: Assembly onto a ring

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Stueck9356,


To make the pattern update during the animation, you will need to change the Update option to 'Active Level' instead of 'Relationships' (the default):





Hope this helps,