Reply

Automatically revise drawings that use the selected 3D document

[ Edited ]

Hi,

 

I'm testing the new built-in datamanagement functions of ST9 at the moment. What I like is the option to keep the Document Number property and Filename in sync. What doesn't seem to work is the Automatically revise drawings that use the selected 3D document option in Settings/Options/File Management:

 

AutoRevise.png

If I 'Revise' of 'Save As' a part in Solid Edge that has a drawing linked to it, no new DFT file is created. In the new Design Manager environment it doesn't work either. I have to do a 'Where Used' search manually to find the linked draft.

 

Am I doing something wrong or does this function just don't work?

 

Regards,

Robin.

8 REPLIES

Betreff: Automatically revise drawings that use the selected 3D document

Hi,



does the documents file names have the revision separator in it or not.

 

I think this is substantial to the automatism for revision the draft as well.

 

And besides that, is the directory You use for thos documents in the indexed area?

 



regards
Wolfgang

Betreff: Automatically revise drawings that use the selected 3D document

Hi,



I have forgotten to mention the FastSearchScope.txt in the preference folder

 

There should be an entry for the folder (start folder) where Your files are saved

 

 



regards
Wolfgang

Betreff: Automatically revise drawings that use the selected 3D document

Hi Wolfgang,

 

  • Our file name format is: 3524-34-004_A.asm, 3524-34-004_A.dft
  • The revision separator symbol is set as _ (underscore character), starting revision value to A
  • Folders are indexed and displayed in green in Design Manager.
  • I added the parent folder \\FS01\Data$\Products to the FastSearchScope.txt 

All other functions that rely on indexing work fine (Where Used, Enforce Unique Document Number), but Auto-revise drawing doesn't. Can you elaborate your settings/workflow/steps to reproduce?

 

 

Betreff: Automatically revise drawings that use the selected 3D document

Hi Robin,




no not really.

But as You have described the behaviour was seen by myself two days ago.

 

But there it was an older part and draft file not using the current revision delimiter so I thought this might be a reason.

After changing the filenames to the current format and trying again, the revision with automatic revise of draft worked fine.

 

The only what might help You at the moment is, that I have seen same at least once 

 

But on the other hand, I can see a wrong behaviour of the "Where Used" search for parts not showing the draft files although the recommended "FastSerach" options are set correctly.

 

I also - see my thread - have big problems with the search for numbers in "Document Number" field as well as title and filename

 

The index search seems to be very very buggy, and - this is my biggst issue - nobody can say what really are the reasons therefore.

 

 



regards
Wolfgang

Betreff: Automatically revise drawings that use the selected 3D document

Hi,

 

Wolfgang is absolutley correct in that you will need to add the the correct entries to the "FastSearchScope.txt" file. This is in the Solid Edge preferences folder

 

The entries you need to add will be the paths to the top level folders (indexed folders) where your Solid Edge data is stored.

 

Once you do this the drawings will automatically revise with the parts

Best Regards
Jon
Technical Manager
Majenta PLM

Betreff: Automatically revise drawings that use the selected 3D document

I know and I did that before my first post, but it doesn't work.

 

I did another test and added a line \\FS01\Data$\Orders to FastSearchScope.txt

My test data is in folder \\FS01\Data$\Orders\2016 vanaf SO11471\P14911 SLH-TGV (Technetium generator)\3d model. Because \\FS01\Data$ is mapped as G: drive I also tried to add G:\Orders to FastSearchScope.txt

 

Still no result...

 

 

Betreff: Automatically revise drawings that use the selected 3D document

Hi,

 

Can you try reregistering SEPropertyHandler.dll?

 

1. Open command prompt with admin priviledge -

2. Change directory to <SE install dir>\Program

Ex. cd c:\Program Files\Solid Edge ST9\Program

3. Unregister SEPropertyHandler.dll

regsvr32 -u SEPropertyHandler.dll

4. Register SEPropertyHandler.dll again

regsvr32 SEPropertyHandler.dll

 

Apart from this also ensure indexing is completed. and then try again.

Please note: In Fast searchscope dont use mapped location path like G:\Order\... use UNC path \\FS01\Data$\Orders\...

Betreff: Automatically revise drawings that use the selected 3D document

Hi,

 

Thanks, reregistering SEPropertyHandler.dll did the job! The strange thing is I've done that before when the Where Used in Design Manager didn't yield results. But I may have done a complete reinstall of ST9 since.

 

To be honest, at the moment all ST9 functions that rely on Windows indexing are a hit and miss experience. Built-in Data Managment looks very promising, so I hope you can work out the quirks.