Reply
Solved! Go to solution

Can't install/update Machinery Library to Standrad Parts

Hi Edgers,


just was running into a major problem.

 

I just wanted to install/reinstall/update my Machinery Library ST9 to the existing local database

 

After getting the same error message again and again, I completely uninstalled Solid Edge Machinery Library, Standard Parts Admin AND Solid Edge itself.

I also deleted every Solid Edge entry in registry, in programs and %appdata%

 

From scratch I installed Solid Edge ST9, Standard Parts Admin, Machinery Library and MP07 (just released)

 

And I can not add to database the standard parts from Machinery Library.

 

Always got an error message indicating "Not the right Install DB

 

Also downloaded Standard Parts DVD from Siemens server again, qand used that one.

 

No success.

Now I'm starting to loose any of my standard procedures to solve such problems.

If even a complete new install will not solve that issue?

 

Does anybody out there have any good idea what else can help?

 

Thanks in advance

 



regards
Wolfgang
3 REPLIES

Re: Can't install/update Machinery Library to Standrad Parts

Did you run the configuration wizard?

Bruce Shand
ST9 MP8 - Insight - Win10 - K4200

Re: Can't install/update Machinery Library to Standrad Parts

Hi @bshand

 

 

 

sorry I've forgotten to tell YOu this too.

 

Of copurse, i did the standard initial procedere for Standard Parts.

And I can use it!

The example DB parts are there and can be used without any problem.

So SQL seems to work, database is here, parts are there.

But only after installing the Machinery Library (complete database of standard parts) and when I want to add them to the DB, then I got the error message that this installation DB (MachineryLibrary_DE_V14_00.ddb) is corrupt and not in the correct format.

 

So I unsinstalled - everything, even Solid Edge ST9 - did a complete reinstall, with all modules in the correct order, without any changes reagrding this error.

 

OK., next assume, my DVD image of Machinery Library is defect.

So I downloaded it again from Siemens server, used this ney copy for a new installation - and got exactly the same.

 

Now I only have an idea, that something happend in the meantime with win 10, win 10 updates, etc. what causes the installer to use those DDB files from library.

 

Any idea and help is really welcome

 



regards
Wolfgang
Solution
Solution
Accepted by topic author hawcad
‎05-23-2017 03:43 AM

Re: Can't install/update Machinery Library to Standrad Parts

Hi Edgers,


thanks for all efforts helping me to solve that issue.

But it seems, as there is no help possible.

 

Just phoned with GTAC and they found that this problem is caused by a .NET version problem of Standard Parts Installer Database.

 

The only solution, and this I already have done is to install them via folder rather than via DDB.

 

And as long as this will not be fixed per MP or version upgrade it will be the only way to procede.

 

 



regards
Wolfgang