Can't select plane in assembly for mating

Pioneer
Pioneer

Having an issue this morning that I haven't had before. 

 

In the assembly I am trying to mate one part to another using their planes, and for some reason SE won't let me pick it by it's plane even if I toggle on/off, or reboot SE. I tried another subassembly file and mating with planes works just fine. It doesn't let me pick any planes in the assembly I am having problems with. 

 

Is there a setting perhaps that I toggled inadvertantly? Thanks!

 

 

19 REPLIES

Re: Can't select plane in assembly for mating

Shift allows the selection of part based planes from the assembly level... 

 

but during the mate command I dont know that this should be needed...

 

but its worth a shot...

 

 

 

 

===================================================
Matt Johnson
Solid Edge Certified Professional (ST7 & ST8)
Solid Edge ST9 (SEEC) - Production
NX10 (Tc Integration) Pre-Production Testing
Teamcenter 10.1.6

Re: Can't select plane in assembly for mating

Pioneer
Pioneer

The ability to select planes is always on by default but you have to turn on part planes with show/hide. But for some reason in this assembly I can't mate with the selection of any of the part's planes. 

Re: Can't select plane in assembly for mating

odd..   what happens if you add another instance of the saem part you are having issues with..  can you mate the new instance as expected?

 

===================================================
Matt Johnson
Solid Edge Certified Professional (ST7 & ST8)
Solid Edge ST9 (SEEC) - Production
NX10 (Tc Integration) Pre-Production Testing
Teamcenter 10.1.6

Re: Can't select plane in assembly for mating

Siemens Phenom Siemens Phenom
Siemens Phenom

Is it the part's reference planes you are trying to use or some other plane in the part? Are you using reduced input mode?

 

Greg

Re: Can't select plane in assembly for mating

Pioneer
Pioneer

I am trying to mate with the part reference planes. To be clear no part in the entire assembly will let me use it's reference planes to mate. 

 

I tried toggling on and off the reduced mode and it doesn't seem to make any difference. I cannot select the reference plane to mate. Thinking about reinstalling ST9 as I just recently upgraded with the subscription, but I wonder if it's just a setting I toggled by accident that is saved to the assembly configuration file. It doesn't behave like this with other assemblies. 

Re: Can't select plane in assembly for mating

Esteemed Contributor
Esteemed Contributor

Mind posting a video of the entire SE application so we can see what you are seeing?


Thanks,
Ken

Production: ST9 MP10
Testing: ST10 MP3

Re: Can't select plane in assembly for mating

Honored Contributor
Honored Contributor

I have had this problem when the vid card runs out of memory. If a reboot solves it that's the issue.

 

ST9 is really bad in terms of Vid memory clean up w/ Nvidia. I have to reboot every 45 min to 3 hours. depending on the polygon count of the models I use.

 

There are few symptoms that tell me The leaks in Vid ram have gone too far:

Can't selects a sketch

Can't select a plane

Display of a part(s) become grainy

Display update becomes low frames/second

 

What can we do about such things? Can't really move back to windows 7 at this point, perhaps GTAC could let us know what  vid card works nice.

 

Getting another Nvidia card with more memory may lengthen the reboot interval, but would not expect it to solve the problem. The whole reason to use Quatro line is the Vid ram parity check. But since SE does not require it, they may not use it at all. I suspect that is the core of the problem.

Re: Can't select plane in assembly for mating

Pioneer
Pioneer

Had issues like this and they are frustrating. SE seems to lose it as you mention after awhile (few hours) and you are forced to reboot your computer to resolve this. As you said, it includes but isn't limited to not being able to see selections you made (you can mate a part and it won't hightlight even though it is selected), parts are partially missing almost like you have a section view. (This happens in programs like Sketchup too a lot) 

 

Here is a quick video of my problem though:

 

https://drive.google.com/file/d/0B5xx8CbjJsQoQy05WkU3VWNwMUU/view?usp=sharing

 

First part I insert the same part into a new assembly and with the reference planes turned on I can select any of them that I want regardless of the view orientation. 

 

Second you see the part in the assembly I am having issues with, can select any of the faces but none of the reference planes. I really don't want to re-create this sub-assembly from scratch, I have a list of parts already mated, and I use reference planes almost constantly for mating. (who doesn't, right?)

 

I should say I tried reinstalling SE completely last night with no avail. Are there file specific settings that can be accessed to see if I have this selection of reference planes turned off? Thanks guys.

 

 

Re: Can't select plane in assembly for mating

Honored Contributor
Honored Contributor

Hi,


it will be to much asking wether You can upload this example assembly structure for testing.

 

I can not see exactly where and what You are selecting (since only the main window is showing rather then the full SE screen.

 

Besides the hole discussion about ios this a bug or not let me ask another question:

 

Is a mate connection using the plane the most efficient  method to do?

Or might a more practical relation be better and maybe even easier?

 

I normally avoid any assembly relations using ref planes, coordinates systems and so on since in reallity they are also not available for usage.

But this is an OT

 



regards
Wolfgang