Cannot align sketch to surface edge

Pioneer
Pioneer

I am learning Solid edge, going thru the online tutorials. This was working last week but I think some setting got changed or something.

 

Here is an example from the tutorials.

 

https://docs.plm.automation.siemens.com/data_services/resources/se/108/help/en_US/selfPacedExt/xid10...

 

In this example a slot is sketched on the slanted face, on page 5 the slot is aligned to be centered on the face. When I do this I select Relate Horizontal Vertical, select the midpoint, then I try to align either the line or the arc of the slot but no midpoint snap appears when I hover over the face edge. I have the file saved from when I did this last week. If I open that file, the relationships are there. But if I delete the alignment relationships I cannot recreate them, the same thing occurs. The snaps are checked on the ribbon under both Sketching and 3D sketching.

 

 

15 REPLIES

Re: Cannot align sketch to surface edge

Phenom
Phenom

In the PathFinder, locate the sketch in its collector, right-click on the sketch and select 'Lock Sketch Plane" from the pop-up menu:

 

2016_Oct_04_01.png

 

~Tushar Suradkar

fb.pngSolid Edge Users Facebook Group

Re: Cannot align sketch to surface edge

Pioneer
Pioneer
Thanks for the suggestion, unfortunately it doesn't help. Still cannot align to edge.

Re: Cannot align sketch to surface edge

Phenom
Phenom

Can you post a video of how you are performing the step 5 from the tutorial. Solid Edge has built-in video recording facility.

 

Else just post the part in its current state at step 5 and I will have a look at it.

 

~Tushar

 

Re: Cannot align sketch to surface edge

Pioneer
Pioneer

Re: Cannot align sketch to surface edge

Phenom
Phenom

I have to retract my earlier solution since it is redundant, for I found meanwhile that Locking the Sketch Plane is not required. I was able to align the midpoints even without the locking.

The part too does not have any problems; I guess it would be your settings that is causing the problem, but difficult to guess which ones.

Sorry could not be of help more than this, post a video of how you are doing the step 5, here's mine:

 

Re: Cannot align sketch to surface edge

Honored Contributor
Honored Contributor

I have problems like this frequently. The typical issue is that even for an instant, the surface the sketch was created on was not available. To correct, you edit the sketch and tell it what plane it lives on again. This in turn can force you to edit the sketch to make it correct again.

 

Sometimes is easier to start over with the sketch. Everything downstream is lost and must be re-done.

 

 

Re: Cannot align sketch to surface edge

Esteemed Contributor
Esteemed Contributor

@12GAGE, this part is a synchronous model

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: Cannot align sketch to surface edge

Pioneer
Pioneer
I have tried that. I created a brand new drawing, place a solid, put a sketch on a face, the same thing happens. And the part I made last week when first doing the tutorial had the sketch-face relationships, if I open that drawing up and delete a relationship, it cannot be created.

Re: Cannot align sketch to surface edge

Esteemed Contributor
Esteemed Contributor

Make sure that the "Components" option is on as shown.

 

2016-10-04_11-01-52.png


Thanks,
Ken

Production: ST9 MP10
Testing: ST10 MP1