Center distances

Valued Contributor
Valued Contributor

Hi There, 

 

I try to take a distance from center to center but Solid Edge does not give me the attachment points of the center. Anyone know if this is a known problem or if there is way to fix this?

 

Thx

 

Alex

 

 

(view in My Videos)

Good Marketing makes the company look smart.
Great Marketing makes the customer feel smart.
11 REPLIES

Re: Center distances

PLM World Member Legend PLM World Member Legend
PLM World Member Legend
It appears that the edges you are selecting are not arcs or circles, but curves. Try using the Inquire element tool to select those, and see what type of element they are. The Optimize command might help you clean up imported geometry.

HTH,
Jason

Re: Center distances

Valued Contributor
Valued Contributor

Thank you Jinglis for your quick reply,

 

I can assure you that it really is a perfect circle. For a better understanding, I masked some parts. I show you here from two perfectly round tubes.

 

Alex

 

 

Good Marketing makes the company look smart.
Great Marketing makes the customer feel smart.

Re: Center distances

Valued Contributor
Valued Contributor

Video is not working anymore...

Good Marketing makes the company look smart.
Great Marketing makes the customer feel smart.

Re: Center distances

PLM World Member Legend PLM World Member Legend
PLM World Member Legend
They may look like perfect circles, but if the models were created in some other CAD, and translated, they may be represented by curves instead of actual arcs and circles. The Inquire Element tool will tell you if they are curves or circles.


Jason

Re: Center distances

Valued Contributor
Valued Contributor

 

These elbows are from our database and created by us probably in SE vs14 or 15.

 

The problem is general. With every round parts, not just these elbows.

It's a new issue since the installation of ST7. I did not have this problem in ST5.

 

Capture.JPG

Good Marketing makes the company look smart.
Great Marketing makes the customer feel smart.

Re: Center distances

PLM World Member Legend PLM World Member Legend
PLM World Member Legend
Hmmm. In your first video, it was highlighting sections of the arc, not the full circle, and wasn't showing the correct glyph. I tested this in ST6, and it worked as I expected. I just tried it again on my test machine with ST7, and had a result similar to yours. Try using the measure minimum distance command with it set to keypoints. This worked as expected in ST7.

Jason

Re: Center distances

Esteemed Contributor
Esteemed Contributor

Try changing the selection filter from "All Elements" to "Keypoints".


Thanks,
Ken

Production: ST9 MP7
Testing: ST10

Re: Center distances

Valued Contributor
Valued Contributor

Work fine with Keypoint instead of All Elements.

 

Thank you Grundey.

Thank you guys for your time.

 

Alex

Good Marketing makes the company look smart.
Great Marketing makes the customer feel smart.

Re: Center distances

PLM World Member Legend PLM World Member Legend
PLM World Member Legend
In ST6 I had it set to All elements. With the same setting in ST7, the result is different. Is this a WAD, or a regression?