Reply

Centerline dash spacing changes when zooming in

So my company is switching us over from SolidWorks to Solid Edge and I have been having some "growing pains" to put things kindly. We are currently in ST5, soon to be upgrading to ST8. I have been able to tolerate most things so far and some googling has managed to get me tutorials to get around most my basic issues, but one thing I just came across is something that seems completely foollish to me and I cant find a way around it.

 

When I place a centerline on my part using the centerline tool and then zoom to extents to see the entire sheet I cannot even tell my line is a centerline, the spaces in it change based on how close I am zoomed in, which completely defeats the purpose of a centerline to begin with. Does anyone know how to change this setting(I am assuming there must be one somewhere because this completely violates basic engineering principals)

 

Pictures to explain what I am seeing: 

Extent zoom.png

If i zoom to extents this is what I see on my part, you can barely tell that line in the center is a actually a centerline, it actually looks more like one here than it does in SE. Overall my point is that this is completely insufficient to depict a centerline.

 

However when I zoom in we see this:

Zoom in 1.png

This looks much more like a centerline and I would be able to work with it in my drawing, but I need it to look like this when I save my PDF version of the file, which it will not as SE makes the PDF depict what it looks at the extent view.

 

Curiously enough, when I continue to zoom in I get this:

zoom in 2.png

 

So it now shows even more dashes in the lines, and if I continue to zoom in there are just more, and more, and more. There is no logical reason for this functionality. The number of dashes should be a function of the length of the centerline, not how far zoomed in I am.

 

Does anyone know a way to fix this? Or even better yet, why in gods name would Siemans ever make this the default setting?

 

Thank you,

Steve

 

 

 

 

18 REPLIES

Re: Centerline dash spacing changes when zooming in

I see the same and always have... it's just in the display.

 

You can toggle on "Display as Printed" and you should then note that it stays static.

 

I cant explain why it's acting dynamic but can confirm that it does... but in reality is not...

 

http://screencast.com/t/U3uoLK8Ni

===================================================
Matt Johnson
Solid Edge Certified Professional (ST7 & ST8)
Solid Edge ST9 (SEEC) - Production
NX10 (Tc Integration) Pre-Production Testing
Teamcenter 10.1.6

Re: Centerline dash spacing changes when zooming in

Where is this "Display as printed" setting? I am pretty new to this software and really dont know where to look for something like that, I dont see it in the display settings under "Solid Edge Options"

Re: Centerline dash spacing changes when zooming in

Hi,



when You have a draft opened then You will fin it in the Options - Display

 

20161101_1630.PNG



regards
Wolfgang

Re: Centerline dash spacing changes when zooming in

[ Edited ]

Hi,

 

 

to answer the question about the "Why?" I only can give my personal opion about it.

 

It is to guarantee that the center line always is seen as a center line independently fromo the zoom factor.

So the center line style is a fixed pixel size on screen and meybe has also to do with Your screen resolution.

 

The option "Display as printed" not only has an effect on the center or hidden line styles but also on the pen/line thickniss or the hatch appearence.

If it is set to ON it could be, that You will not see any hatch if zoom to close as well You only see a black area when look onto the entire sheet.

Also line thickniss IMHO is to "strange" if set to "display as printed"

 

I normally haven't it turned on.

 

But - as always - this is a matter of personal decision.

 

 



regards
Wolfgang

Re: Centerline dash spacing changes when zooming in

[ Edited ]

There is no option for "Display" in ST5's "Solid Edge Options" there is "Edge Display" but "Display as printed" is not in there.

 

Steve

Re: Centerline dash spacing changes when zooming in

Hi Steve,


this entry is there right from the beginning as I can remember.

 

But, do You haved opend a draft or is it a part model?

 

 



regards
Wolfgang

Re: Centerline dash spacing changes when zooming in

Hi Steve,


we are talking about the general options of Solid Edge not the view properties!

 

20161101_1703.PNG



regards
Wolfgang

Re: Centerline dash spacing changes when zooming in

you have to be in a draft...

 

options,  view tab, Disply as printed is a check box.

 

i agree with Wolfgang...  i have never left disply as printed on unless i was checking a specfic detail or hashing...

 

 

===================================================
Matt Johnson
Solid Edge Certified Professional (ST7 & ST8)
Solid Edge ST9 (SEEC) - Production
NX10 (Tc Integration) Pre-Production Testing
Teamcenter 10.1.6

Re: Centerline dash spacing changes when zooming in

Thanks Matt, it was in view, I was looking for something that said "Display" per Wolfgang, but that wasn't an option. 

 

Either way I found an alternate way of doing things, I clicked on the centerline, went into properties of the line itself and changed the line type, there is one that is more like a normal center line. I still just wish there was a way to make the spacing of the dashes a function of the overall length of the line itself(or at least display that way when zooming to extents) as you would with normal drafting, but I guess this will do.

 

Thanks all.

Steve