Cancel
Showing results for 
Search instead for 
Did you mean: 

Cursor is slow to respond and accidentally drags and drops copies of parts into the assembly

Pioneer
Pioneer

Since upgrading to ST10, I've encountered an old problem that occurs when I click on a part file while in an assembly.

 

If I move the mouse too quickly after clicking on the part icon in the assembly tree, Solid Edge still thinks the "click" on the part is active, and drags and drops a replication of the part into the assembly.

 

It's easy to back out of this, but it's annoying. Does anyone know of a way to fix this issue?

 

Many thanks!

John

MSI WT-70 2OK;
Nvidia Quadro K3100M
WIN10 1709:16299.461
SE ST10 MP8
5 REPLIES

Re: Cursor is slow to respond and accidentally drags and drops copies of parts into the assembly

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Sounds like you have the Win10 Fall Creator's update? Build 16299. Assuming you are running Win10.

This is a known issue and causing many users grief. We're waiting for Microsoft to release an update to fix it.

See this if you like:

https://community.plm.automation.siemens.com/t5/Solid-Edge-Forum/ST9-Dialog-windows-slow-down/m-p/44...

Bruce Shand
ST10 MP7 - Insight - Win10 - K4200

Re: Cursor is slow to respond and accidentally drags and drops copies of parts into the assembly

Pioneer
Pioneer

Yep. Running Win 10 Version 1709. Fall Creator's update, OS Build 16299.192 - A royal pain it is!!

 

I went into the maintenance portal of my computer and noted that there numerous PS Device Appcrashes - not sure what would have caused these. Furthermore, I noted that my antivirus/firewall (Panda Global Protection) software wasn't active and couldn't make it active. So, I reloaded the antivirus/firewall software (now working), and updated all my drivers. The frequency of freezing incidents has decreased - but it still hangs up occasionally. 

 

I'll send out an update in a few days. 

 

John

 

 

MSI WT-70 2OK;
Nvidia Quadro K3100M
WIN10 1709:16299.461
SE ST10 MP8

Re: Cursor is slow to respond and accidentally drags and drops copies of parts into the assembly

Phenom
Phenom

I never use the drag to insert and I don't want that functionality so I hope in a future release where I can disable it.

Re: Cursor is slow to respond and accidentally drags and drops copies of parts into the assembly

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @jstockton,

 

A update from Microsoft has just been posted by @RDH to "OS Build:16299.214" in >this post<.....and currently there is a manual method to download & install it.

 

Definitely be worth grabbing, but also to see if it helps in this issue.

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge 2019 [MP1] Classic [x3 seats]
Windows 10 - Quadro P2000

Re: Cursor is slow to respond and accidentally drags and drops copies of parts into the assembly

Phenom
Phenom

@SeanCresswell wrote:

Hi @jstockton,

 

A update from Microsoft has just been posted by @RDH to "OS Build:16299.214" in >this post<.....and currently there is a manual method to download & install it.

 

Definitely be worth grabbing, but also to see if it helps in this issue.


In my tests this issue is resolved too