Reply

Dimensions on a part

Hello, 

 

For some reason all of a sudden i can¨t change the dimensions in my modells. (obviusly I did something but I have no idea what) The dimension is first of all in a lighter blue then normal and when i try to edit it I can change the value but the line stays the same and the value get a line under it. 

 

When I go to tools>variables the valuebox is grey instead of white and can¨t be edited. What did i do and how can I fix it? Please help me! 

 

FYI I use Solid Edge ST8. 

 

Regards Gustav

10 REPLIES

Re: Dimensions on a part

Maybe you are placing PMI dimensions in ordered?

...........................................................................................................
Solid Edge ST9 & AutoCAD 2018 user

Re: Dimensions on a part

Hi Gustav:

 

From the help:

"Locked dimension is a dimension whose value controls the size, orientation, or location of an element. A locked dimension prevents the dimension value from being changed when a connected face is moved or resized. Also, a dimension must be locked if you want to use it in the Variable Table.
It is easy to identify a locked dimension. In the graphics window, the default display color of a locked dimension is red.  In Path Finder, a locked dimension has a lock icon in front of its name."

 

You can change the blue dimension to red by clicking its lock icon. Hopefully you will be able to modify it.

 

 

~Tushar

Re: Dimensions on a part

Here you can see how it looks for me. The 700 value is how it looks when I just place the dimension and the 3000 is how it looks when I try to change the value from 3200 to 3000 without anything happening to the lines (the line is still 3200). I do everything in synchronous modelling. 

 

Re: Dimensions on a part


Joris wrote:

Maybe you are placing PMI dimensions in ordered?


Good point @Joris

In that case the dimensions would be purple/violet or what ever that color is, my defaults are 120,60,180 while Gustav mentions 'lighter blue' so it is puzzling unless we have a image of the screen.

Re: Dimensions on a part

The screenshot is clear.

Click on the lock like @Tushar showed.

...........................................................................................................
Solid Edge ST9 & AutoCAD 2018 user

Re: Dimensions on a part

I figured out that for some reason the "driving dimension" buttun is grayd out and I cannot change from driven to driving. Why this happend and how to fix it I do not know (yet). Sure I can lock the dimension but that is not what I want to do. I am used to work with unlocked driving dimensions for easy changing the modell so what I need help with is how to change back to driving dimensions from driven. 

 

 

Re: Dimensions on a part

[ Edited ]

I think the dimension with the value of 3200 is not the dimension of the sketch, that's why you could not change it. I think you created it "after" creating your dimentioned sketch.

 

You have to edit your sketch if you are working in the ordered environment.

 

But if you are using the Syhchronous environment you have to delete this dimension and try to edit your model with the Steering Wheel for example. It depends on your way of modeling.

 

Yasser

Re: Dimensions on a part

[ Edited ]

Hi @GustavK,

 

Could it be there are some relationships acting on this profile, forcing it to the original size....I don't see them displayed in your image, so is what made me ask.

Sean Cresswell
Design Manager Streetscape Limited
Solid Edge ST9 [MP8] Classic [x2 seats]
Windows 10

Re: Dimensions on a part

If possible, upload the part file so the problem can be checked.