Cancel
Showing results for 
Search instead for 
Did you mean: 

EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Pioneer
Pioneer

Hello .

I'am preparing BOM. I want to exclude from list of parts those which are not visible in drawing view model.

So in Parts List Properties -> List Control  I turn on the option "Exclude hidden parts". But it doesn't work properly.

See attached video. 

On this video You can see that in first moment  in model view are visible a lot of parts. Then I'am turned off  most of them. In model view are visible only a few parts now. Then I turned on Exclusion of hidden parts in List Control.

List of materials is changing. But You can see that this list is not reflection of parts visibled in drawing mode view.

In model view You can see only few parts. But BOM includes much more parts than only few.

What am I doing wrong?

11 REPLIES

Re: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Pioneer
Pioneer

 I noticed a certain regularity. This error is only if I have more than one sheet in the file. If I have more sheets then the using the "exclude hidden parts" tool causes that in the "BOM" "invisible parts"are not really shown. However, all visible in each sheet are visible.
So the list of materials only shows visible parts but also them from all drawing sheets. So if I have 2 sheets. In each of them aro shown  3 parts, I will have 6 parts on the material list. 

Re: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Esteemed Contributor
Esteemed Contributor

You lost me here:


@SUCHYwrote:

So the list of materials only shows visible parts but also them from all drawing sheets. So if I have 2 sheets. In each of them aro shown  3 parts, I will have 6 parts on the material list. 


Are you saying there are only 3 parts in the assembly but the quantity in the BOM is doubled?

 

Also note that the button says "Exclude parts hidden in all drawing views". So if a part is hidden in one view but shown in another view it will appear in the BOM.

Using a configuration to drive the BOM might be a better way to go.

 

Edit: I watched your video and though I can't read the language it doesn't seem that yours says "Exclude parts hidden in all drawing views" but perhaps does say only "Exclude hidden parts".

What version of SE is it?

 

Bruce Shand
ST10 MP5 - Insight - Win10 - K4200

Betreff: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Esteemed Contributor
Esteemed Contributor

Hi @SUCHY

 

 

the only and stable method to get this is - as menitioned already by @bshand -  to use view configurations from the ASM.

Define the visible parts in the ASM, save them as view configuration and use that for showing the parts in the draft view as well as to define the members for the BOM.

 

This will work, and even is to define easier and faster  due to You do it in the ASM directly.

 

 



regards
Wolfgang

Re: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hi @SUCHY

 

I have run into the same problem. There is an option in the programming environment that allows you to hide lines in the parts list if the items are not ballooned. I have attached a macro I was playing with that will hide any parts list line if the item is not ballooned. It's an as is where is, so no guarantees.

Re: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Esteemed Contributor
Esteemed Contributor

@Alan, Sounds intriguing. I'm going to check it out.

Bruce Shand
ST10 MP5 - Insight - Win10 - K4200

Re: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Legend
Legend

Hi @Alan,

 

Can you please write a few words how to operate with this macro?

 

Regards,

Arek


Production: SE ST10 MP6
;

Re: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Here is a quick video to show the macro I have created to update the parts list.

 

https://youtu.be/jI98FfsTfWY

 

I think it might be only doing one list, so I might have to re-assess it.

Re: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Esteemed Contributor
Esteemed Contributor

@Alan, the readme file says:

 

Last modified: February 23, 2017

Source code: PackCalc.sln
__________________________________
General Usage

Open a Solid Edge Draft file that contains a parts list (BOM).
Execute the "PackCalc.exe" using "Run Macro.


You can also add the "PackCalc.exe" to the RibbonBar by using the "Customize RibbonBar" functionality.
 __________________________________

 

So, it should say ItemNumberUpdate.exe instead of PackCalc.exe?

Bruce Shand
ST10 MP5 - Insight - Win10 - K4200

Re: EXCLUDING HIDDEN PARTS DOES NOT WORK PROPERLY - IN DRAFT ENVIRONMENT

Esteemed Contributor
Esteemed Contributor

So, it should say ItemNumberUpdate.exe instead of PackCalc.exe?


To answer my own question: Yes.

 

@Alan, That is a very cool macro!  Would it be possible to make it so if you add a balloon previously removed or not present that the macro will unhide the row?

Bruce Shand
ST10 MP5 - Insight - Win10 - K4200