Cancel
Showing results for 
Search instead for 
Did you mean: 

Error when firing up an "old" macro

Legend
Legend

Hi,

 

When I fire up an older macro original written by Greg Chasteen and  modified by Klaus I get an error.

In version ST 9 it worked.

 

Error.jpg

 

Anyone out there with an idea how to solve this error.

 

Kind regards,

 

 

Jan Bos

Emmen, The Netherlands

 

 

8 REPLIES

Betreff: Error when firing up an "old" macro

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @Jan_Bos

 

 

 

 

 

I suppose - or better I believe I know it - this has to do with the deleting of all 32bit APIs with ST10.

 

 

A very good solution to run them nonetheless is, to extra install "View and Markup" from the installation image.

This is a 32bit application and installes all the necessary APIs for thos old macros.

 

At least here for me it solved all that issues!

regards
Wolfgang

Betreff: Error when firing up an "old" macro

Legend
Legend
It worked... Many thanks Wolfgang.

Betreff: Error when firing up an "old" macro

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @Jan_Bos

 

 

 

welcome and I'm happy to have a solution for the moment.

I'm a little bit angry about what will be if this will not bring the solution in future releases.

 

What shall we do with all the old macros we have.

 

@uk_dave

Here a solution  will be necessary for future releases, to prevent such situations!

 

Macros should work, or at least there is a need for transforming old vb6 macros to .net automatically!

 

regards
Wolfgang

Betreff: Error when firing up an "old" macro

Valued Contributor
Valued Contributor

hi ~ hawcad ..
You are such a wonderful person.
Good information, thank you.

Betreff: Error when firing up an "old" macro

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

HI @Hclee

 

 

 


Hclee schrieb:

hi ~ hawcad ..
You are such a wonderful person.
Good information, thank you.


... 


welcome, and it always is a pleasure to hear such a statement on a Friday afternoon Smiley Very Happy

 

regards
Wolfgang

Betreff: Error when firing up an "old" macro

Creator
Creator

Hi,

 

Could you clarify on were I can find the View and Markup in the installation image? I cannot find it!

 

Thank you in advance!

Betreff: Error when firing up an "old" macro

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @Korst

 

 

 

no You will not find V&M in  the standard installation image of Solid Edge.

There is an extra download file for V&M only

 

Download this one and run the install/setup

 

 

 

regards
Wolfgang

Betreff: Error when firing up an "old" macro

Creator
Creator

Thank you! All my macros work again now! 

 

This week we will look at upgrading to office 64 bit, to prevent this kind of issues for the next update.