Floating License across a VPN

Builder
Builder

I have an old workstation that I am using as a VPN server using Hamachi LogMeIn to share files with a colleague.

 

My SE license is Floating and I have the above workstation serving 2 workstations on my local network with the single seat license.

 

The colleague is off site and I cannot figure out how to get the License Server to serve the off site workstation.

 

Below is the LMTOOLS server status report from the off site workstation:

 

[Detecting lmgrd processes...]

License server status: 27001@T3400

    License file(s) on T3400: \\192.168.1.150\c\SEFlex\Program\SELicense.dat:

 

lmgrd is not running: License server machine is down or not responding.

 See the system administrator about starting the license server system, or

 make sure you're referring to the right host (see LM_LICENSE_FILE).

Hostname:      192.168.1.150

License path:  27001@T3400;

FlexNet Licensing error:-96,491

 

This the same error I received before opening the TCP ports on the server firewall.

 

Am I receiving this error due to Hamachi VPN restricting it? I can't find anything in their settings that would allow me to open ports.

 

Any help here is appreciated.

8 REPLIES

Re: Floating License across a VPN

Esteemed Contributor
Esteemed Contributor

One thing you may be running into is a timeout that FlexLM uses which is typically too short when running VPN over a internet connection.  We have found that this needs increased for WAN links with higher than normal latency and almost all VPN connections.

 

Create a Windows System Environment Variable called "FLEXLM_TIMEOUT" and set it to "3000000" (microseconds).  This will set the timeout to 3 seconds which should be plenty of time to get a license reply.

 

2017-03-16_13-38-57.png

 

 


Thanks,
Ken

Production: ST9 MP7
Testing: ST10

Re: Floating License across a VPN

Builder
Builder
That did it!

Thanks Ken!

Re: Floating License across a VPN

Builder
Builder
One more question:

On the server firewall I had to open all the TCP ports to get it to work. I first tried the 27001 port but no bueno.

What ports need to be allowed in the firewall to make FlexLM work on LAN or WAN?

Re: Floating License across a VPN

Builder
Builder

Ok so this worked for one connection ouside my LAN but the one I need it to work on will not. Same error message.

 

 

 

Here is more detail:

As stated above I am able to connect to the license server on my local network without issue (albeit all TCP ports are open on the server, which I didn't think should be necessary). I am also able to connect to the server via a hotspot internet connection on my cell phone through a usb cable and wifi disabled.

 

Any other connection attempt via the VPN is not accessable. I have tried disabing the firewall on the client workstations and server but no bueno.

 

Any ideas where to look?

 

Thanks!

Re: Floating License across a VPN

Esteemed Contributor
Esteemed Contributor

Using WiFi and the VPN, can you Ping your license server?  If you cannot this will tell you if you have general connectivity issues that would need addressed vs. FlexLM issues.


Thanks,
Ken

Production: ST9 MP7
Testing: ST10

Re: Floating License across a VPN

Phenom
Phenom

Hi 

 

 

maybe You should consider to only use the IP adress rather then the hostname.

The DNS lookup might not be wiorking correctly over VPN.

 

 



regards
Wolfgang

Re: Floating License across a VPN

Builder
Builder

Guys, thank you!

 

It works like a charm!

Re: Floating License across a VPN

Phenom
Phenom

Hi @PM-DC

 

 

 

great to hear
and I'm happy being able to help



regards
Wolfgang