Cancel
Showing results for 
Search instead for 
Did you mean: 

How do you set up dual unit display (inch and mm) as default for the part and draft templates? ST10

Experimenter
Experimenter
Hi everybody: When I am working on a sketch of the part environment (ST10), I would like that every time when I put a dimension, to see both inches and millimeters in the dimension. Right now, I place the dimension(s), then right click and select to show dual unit display. But how I do to save the dual unit display as a default setting in every new part or draft template? Regards, JorgeGRE
10 REPLIES

Re: How do you set up dual unit display (inch and mm) as default for the part and draft templates? S

Genius
Genius

Yes, via your templates. You have to have access to them and be able to save them for your future work.

Betreff: How do you set up dual unit display (inch and mm) as default for the part and draft templat

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @JorgeGRE,

Hi @rbhaskin

 

 

as mentioned either directly in every template or using the Format Styles Organisation functionality 

regards
Wolfgang

Betreff: How do you set up dual unit display (inch and mm) as default for the part and draft templat

Experimenter
Experimenter

Hi @rbhaskin and @hawcad:

I am sorry if I am a little out of date. Last time I worry about the format of a template was with SolidEdge V12 (maybe even before that).

  • By then you open a part template (ISO or ANSI)
  • You go to settings/units and then selected to dual unit display
  • There was a button “Set as default” you made click on that button and all the dimension on that file would have followed that format.
  • Then you could save that file in the folder that contained all the templates.

However, now the environment “settings” vary depending on where you are in solid. This means that to change the dimension format you have to:

  • Open a part template
  • Make a sketch
  • Put a dimension (so the settings window that allows me to select “Dual dimension display” appears when I make right click on the dimension)
  • Give the format I want to that dimension

But the “Set as default” button doesn’t exist anymore. So, if I put another dimension (in the same sketch) it is not coming with the desired format (NOT dual dimension display).

Could any of you tell me in a little more detail how to do this? hawcad, where I can find the route to the functionality “Format Styles Organisation”?

Do you know any links on internet that could help me?

Regards,

JorgeGRE

Betreff: How do you set up dual unit display (inch and mm) as default for the part and draft templat

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Open your part template file and follow the video which shows how to change your dimension style(s).

Do the same for any other templates if needed - asm, dft, psm. All of them have the styles button on the home tab.

 

(view in My Videos)

Bruce Shand
ST10 MP10 - Insight - Win10 - K4200
Highlighted

Betreff: How do you set up dual unit display (inch and mm) as default for the part and draft templat

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @JorgeGRE

 

 

sorry for that late response, I really have forgotten to answer when coming back to the PC.

 

You will find the Style Organizer diectly in the Style form.

 

From here You can copy any fomrat style to any file.

My overall suggestion here always is to copy it to the material.mtl since this will be the global and general store for any settings You have.

And from there You can copy it to everey file You need it.

 

Defining the dimensionstyle once in any part/psm or asm file You directly can copy it from here to the templates You are using AND - as mentioned above - to the material.mtl

 

So You do not need to open any template file individually, but from here.

 

20180330_1544.PNG

 

 

Hope this helps!

 

regards
Wolfgang

Betreff: How do you set up dual unit display (inch and mm) as default for the part and draft templat

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@hawcad  That's true that you can do it from the style organizer. But that's not always clear to a new person. Plus, in my case, the material.mtl is not up to date so I use my .dft template as the master for that usually. Never really understood why the default is material.mtl.

Bruce Shand
ST10 MP10 - Insight - Win10 - K4200

Betreff: How do you set up dual unit display (inch and mm) as default for the part and draft templat

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @bshand

 

 

 

maybe it has historical reasons, but if knowing that the MTL is nothing else than a part, You will use it as depot for all settings and standards too.

 

And You not only have saved the format style settings but the material library too.

 

Maybe this was the original reason for doing it like that.

 

 

regards
Wolfgang

Betreff: How do you set up dual unit display (inch and mm) as default for the part and draft templat

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@hawcad, yeah but if I already have a part file as a template why would I want yet another file to keep track of?

Bruce Shand
ST10 MP10 - Insight - Win10 - K4200

Betreff: How do you set up dual unit display (inch and mm) as default for the part and draft templat

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @bshand

 

 

Yes I agree!

 

 

regards
Wolfgang