Importing METRIC disaster with Assemblies.... and a Mileti Moment!

Phenom
Phenom

I wish someone would address one of the most awful things about Importing foreign DATA.

 

Why Does Solid Edge even ask you what Template to use, when the only Part that gets converted in either Metric or Imperial is the parent Assembly?

 

So I have a customers model all done in SW and Metric. I am being asked to make some design changes on the machine. However even after selecting the METRIC template, all the sub-assemblies and parts are in Imperial.

 

Am I missing something, or is this the most stupid **bleep** thing ever?

 

I've complained about this mant times, and yet I've have NEVER received a descent answer. Please tell there's a way to edit my Template to FORCE EVERYTHING METRIC. At least there should be an Ability in Rev Manager to make edits like easier!

 

Bob

6 REPLIES

Re: Importing METRIC disaster with Assemblies.... and a Mileti Moment!

Siemens Phenom Siemens Phenom
Siemens Phenom

Bob,

See if this would help:

Go into Solid Edge Options-Helpers-Set Default Templates.  Change your template here to Metric for parts, assemblies, etc.

 

When you go to open your customer's file, it will ask what template for your top level assembly but the underlying subs and parts should open with the template you selected in the above step.

 

I think.....

 

Hope this helps.

Kevin

Kevin Grayson
Solid Edge Technical Consultant
kevin.grayson@siemens.com

Re: Importing METRIC disaster with Assemblies.... and a Mileti Moment!

Phenom
Phenom

Kevin,

 

Thanks for looking at this.

 

I looked into that, however all I see is this (see below) and I can't seem to add new Templates to this list. And if I edit the list to point to a Metric Template, I'll lose my Imperial Template.

 

Also I love it when Solid Edge Dialog boxes aren't exspandable... you get tortured even trying to edit this stuff.

 

set templates.png

 

So even if I open up my METRIC Assembly Template, I have gone in and set the Templates to look here:

 

metric temp.png

 

But watch what happens:

 

 

http://screencast.com/t/rTE3BVDm1i

 

 

Bob

 

 

Re: Importing METRIC disaster with Assemblies.... and a Mileti Moment!

Siemens Phenom Siemens Phenom
Siemens Phenom

Bob,

In the Set Default Templates area, instead of adding new templates to this list, select the part template and Browse for your Metric template.  Do the same for your assembly template.

After you open the top level assebly, your subs and parts should be metric instead of Imperial.  I don't think you have to do anything with File Locations/User Template settings.

 

After you open and save your customer's assembly, you can go back to Set Default Templates and switch them back to your original.

 

I hope this works and is what you are after.

Kevin Grayson
Solid Edge Technical Consultant
kevin.grayson@siemens.com

Re: Importing METRIC disaster with Assemblies.... and a Mileti Moment!

Phenom
Phenom

Thanks Kevin, but I find this all very silly. When someone installs Solid Edge, they should expect things such as these to be already set correctly.

 

They should at least give you the option when importing other formats, instead of all this nonsense in the templates... or atleast make it easier than having to go into each template and make manual changes.

 

Again thanks for the suggestion... when I have some more free time I'll see if I can sort it all out. In the mean time every part I'll just go and make the change.

 

 

Bob

 

 

Re: Importing METRIC disaster with Assemblies.... and a Mileti Moment!

Legend
Legend

Doing this really doesn't take that long. Just saying. I'f I was going to get mad at something, it would be unbend not working on lofted flanges, not having to change what is considered the go to template one time so that I can convert an assembly and have it be in metric units. 10 seconds to change that, then convert, then 10 seconds to change it back. Not that bad.

ST9
Windows 7 Professional
Nvidia K2200 & Intel Xeon
"You're doing it wrong"

Re: Importing METRIC disaster with Assemblies.... and a Mileti Moment!

Phenom
Phenom

@nominus38  "Doing this really doesn't take that long."

 

And that's EXACTLY the point... who's "time" is wasted doing such menial things X every user! Well it looks like Solid Edge feels every user needs to do this, instead of one person in Development spending 15 minutes making these options setup correctly for everyone so there's no confusion as to why this happens.

 

 

I have no issues with spending the time to set up a special environment to make things happen correctly. But this is something that a NEW USER might run across early in their evaluation of Solid Edge... and walk away in frustration.

 

But even experienced users should not be asked to go into the bowels of Solid Edge's options, so that when importing an Assembly using a Metric Template, that all the sub assemblies, and parts are also imported using the proper templates... this is downright absurd!

 

There should be something in Property Manager that would allow you to edit this IMPORTANT property for each of the Assemblies, Parts, SM, etc. to whatever it needs to be.

 

Bob