Cancel
Showing results for 
Search instead for 
Did you mean: 

Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Valued Contributor
Valued Contributor

Started to update an old Keyshot file, and after update the Solid Edge file linked to it, all cameras changed inside KS window, even when in 'locked' state ... And strangely, the values of Position, Orientation and Perspective are intact. 

 

Tried to duplicate the 'old' cameras ( done in KS 6 version), but they act in same way ( the camera view changes )

 

 

Any ideas how to solve this issue on this new versions and integration between SE and KS ? As I'm doing new versions of old renderings, the Cameras should be the same ( settings and viewport )

 

*Already updated to KS 7.2 and using SE ST 10.

 

Thanks

BR

---------------------------------
Hilario, Flavio
Industrial Designer
ST10 / Win10
8 REPLIES

Re: Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Valued Contributor
Valued Contributor

It seems the Keyshot plugin is doing some kind of change in the model inside the renderer from Solidedge after the Render Update ... most of times it rotates 180 degrees at Z (Solidedge) axis, but depending on what you do inside Keyshot before click the SE Update button, it rotates the model in a weird way.  In the first example in the attached image ( left side = before the Render Update ...  right side = after the Update from SE window), can see only the SE model was afffected. The other objects ( from another keyshot file imported to the scene) are really intact. It proves is not a camera bug. The bug is more related to SE model inside the scene. ( or something that ST10 or the plugin do differently of previous versions - I beliee in some coding conflict)

I reported the error at the 'Bugs and Issues' forum of KS, but no answers yet.  Anybody else here on 'SE world' notices that strange thing when updating an old file (KS and SE) to the new softwares versions? Unfortuantely is not good idea to get back to Keyshot 6, because I've been saving some scenes already (new materials, cameras, etc) in KS7.

---------------------------------
Hilario, Flavio
Industrial Designer
ST10 / Win10

Re: Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Siemens Phenom Siemens Phenom
Siemens Phenom

Flavio,

I run ST10MP5 & KS 7.1 and having both applications open, add e.g a 'round' in SE, select 'Keyshot update', and the model is updated in KS without any view changes.

 

What workflow should I use to reproduce?

 

/ulf

Siemens EMEA GTAC Support

Re: Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Gears Phenom Gears Phenom
Gears Phenom

Hi @F_Hilario

 

I'm on SEST10MP5 and KS7.2 and I have a same issue as yours, but it works well on KS6...

 

BR,

Imics
http://solidedgest.wordpress.com/

Re: Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Valued Contributor
Valued Contributor

Hi Ulf.

 

In my case I have old keyshot files ( KS6 ) and Solid edge files (ST8), and I will generate new renderings with some modifications made in the Solidedge files ...  KS 7.2 itself works fine ( cameras, hide/show sets, materials , etc etc )  until I update the Solidedge files linked to a KS file. 

 

When I update ( in the Solidedge side ) , the KS window - with the file opened and correctly detected by SE - acts strange, changing the position of the objects inside the scene and ambient ( and that happens either if I change the Soliedge file , either if I do nothing else but just clicking the 'Keyshot Render'  ( and in that case, nothing should change in KS side ... maybe just the link information would change, but that is 'invisible' to the user.

 

I have in plans to test with the KS 7 or 7.1 , or even get back to KS 6.2 that I was using before with SE ST8 ( I'm not really sure if ST10 MPxxx  will work fine with KS 6.xxx but I will give a try anyway )

 

 

Thanks for your help and reply, guys .

 

BR

---------------------------------
Hilario, Flavio
Industrial Designer
ST10 / Win10

Re: Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Valued Contributor
Valued Contributor

Hi Imics

 

You working with KS 6 and 7 with ST 10 MP5? 

KS 6 working fine with ST10 as it used to work with ST7, 8 and 9 ?

 

Thanks for your reply.

 

 

---------------------------------
Hilario, Flavio
Industrial Designer
ST10 / Win10

Re: Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Siemens Phenom Siemens Phenom
Siemens Phenom

Flavio,

I don't have similar old renders to test with. Maybe log something with your support?

Hopefully, you see better functionality in the newer versions. 

 

Good luck /Ulf

Siemens EMEA GTAC Support

Re: Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Gears Phenom Gears Phenom
Gears Phenom

Hi,

 

First I used ST10MP5 and KS7.2, but I have same issue so I had to use ST10MP5 and KS6. My camera issue has been solved.

 

This was the result:

 

BR,

Imics
http://solidedgest.wordpress.com/

Re: Keyshot not keeping Camera views after Solid Edge files update (ST 10 + KS 7 )

Valued Contributor
Valued Contributor

I'm still having issues .... on both machines ...

 

Followed some instructions on this post   https://community.plm.automation.siemens.com/t5/Solid-Edge-Forum/Update-model-in-KeyShtot-from-Solid...

 

Tried KS 6 (installed with ST10 DVD ) , 6.1 and 6.3 .  I suspect KS 7.2 infected something else on my Windows (or it was Windows itself - the most recent one - as I update it automatically )

 

Here I uploaded some examples .. I'm also chatting w people in Keyshot forum.  Probably next week i will try a complete PC format and reinstall ...

 

https://1drv.ms/v/s!ArCsO8vnYMx-tLZUTEBCdGvIy3xVNg

---------------------------------
Hilario, Flavio
Industrial Designer
ST10 / Win10