Cancel
Showing results for 
Search instead for 
Did you mean: 

LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Genius
Genius

My download of the fixed version of ST10 went well. However, today I tripped across the first bug.

 

Under the Block/Edit environment, there are no commands to chose from listed on the left side of the CUSTOMIZATION dialog box for any menus. This is what I see: https://www.screencast.com/t/SHUyvgbuJY

 

Thanks,

Ron

 

12 REPLIES

Re: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @ronlatour,

 

I see you also have no active [selected] environment to customize.....is there anything available in the drop downs?

 

This looks to me, very much like a corrupt user account profile.....but could easily be something else going on here.

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge 2019 [MP2] Classic [x3 Seats - Cloud Enabled]
Windows 10 - Quadro P2000

Betreff: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @ronlatour

 

 

 

 

as mentioned by @SeanCresswell this seems to be a problem with Your user profile and maybe old SE data.

 

I would try to go to the %appdata% folder, and would rename the "Unigraphics Solution" folder to UG_old

 

Then start Solid Edge again and see what's happen then.

 

I hope it will be better now

regards
Wolfgang

Betreff: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Genius
Genius

Wolfgane/Sean, thanks for the suggestions. Here's the answers:

 

Re "is there anything available in the drop downs?":

No, they're grayed out.

 

Re "go to the %appdata% folder, and would rename the "Unigraphics Solution" folder to UG_old":

I need help to be sure what I'm doing. Here’s a screen capture of what/where you've directed me. https://www.screencast.com/t/Kl9gBJVo. Please advise if this is the correct spot. It looks like the US folder has 3 versions of SE including the latest.

Further, I just realized that I may be the culprit. I clicked on the .exe file, first in the download dialog box within MS Internet Explorer and when it didn’t immediately activate, I went to my DOWNLOADS folder & clicked on the .exe file there. When I got indications that both downloads were in progress, I cancelled both and started again. Could this have caused a corrupt download?

 

Thanks again,

Ron

 

Betreff: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

HI @ronlatour

 

 

 

Yes You are at the right position.

 

I would rename the complete Unigraphics Solutions folder.

I think the existance of those older version subfolders could be a reason of Your problems.

When an older version settings folder is detected, then Solid Edge copy these into the current version.

Thee were modifications during the version history.

So I always recommend to renmae this folder first before starting a new version of SE once.

 

This will give You the new and current default settings and menu and ribbon bar settings.

 

 

regards
Wolfgang

Betreff: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Genius
Genius

Wolfgane, I did as you indicated and still see the same thing. Except that maybe I initially failed to see that the drop down for the ENVIRONMENT TO CUSTOMIZE; although grayed out, would drop down if I clicked on the carrot. If I make a selection, then I get a full command screen on the left side. Here’s a capture of what I mean: https://www.screencast.com/t/2T0K6WeYlg

 

This leads me to ask two questions as follows:

 

  1. Which environment is considered the BLOCK/EDIT one because there is no name indicative of this situation like there is for BLOCK/OPEN. Further, why doesn’t it show up automatically when I chose CUSTOMIZE in the BLOCK/EDIT environment as it does in other environments?
  2. The US folder in C:\Users\Ron\AppData\Roaming was corrected by SE and only the folders for Ver 110 now shows up. Unfortunately, I’ve loss all of my customizations carried over from ST9. Is there no way to get these back? 

A quick answer will be appreciated since I’m stuck with the choice of proceeding to redo all the customizations (a lot of time) or wait for your answer before I can do any work.

 

Thanks,

Ron

Betreff: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

Hi @ronlatour,

 

I see the below available for "Draft - Edit Block" customizing.

 

2017-12-20.png

 

2. This is why @hawcad advised to "rename" the previous user settings [in case it made no difference].....as there is clearly an issue somewhere between then & now. I think it safer to just try to tweak it to how you remember it was, than to bother grabbing parts of the previous settings files, given this issue.

 

Anyway, it looks like you are on the way back to normal......sanity restored, I hope. Robot wink

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge 2019 [MP2] Classic [x3 Seats - Cloud Enabled]
Windows 10 - Quadro P2000

Betreff: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

HI @ronlatour

 

 

as You see that now the UI is here again, this shows that it had to do with Your old settings.

 

Thee were so many changes with the different versions, that the best I can recommend is, to adapt the new ST10 settings to fullfill Your request rather than using the old but wrong settings.

 

And if there are any necessary and wanted settings, still rename the new "Unigraphics Solution" folder to "Unigraphics Solution ST10" and the old back to "Unigraphics Solution"

Immedeately aftwerwards when YOu restart SE You should see Your old tabs and ribbons.

 

But again, and thanks to @SeanCresswell  for confirming it,  I think it would be better to use the new one.

regards
Wolfgang
Highlighted

Betreff: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Genius
Genius

Wolfgang/Sean, I'm not sure where you obtained the screen capture that you posted showing the DRAFT - EDIT BLOCK environment. But if you look at my video capture that I posted, there is no such selection available. Nor is there one when I open SE/BLOCK/EDIT/CUSTOMIZE. So there is something wrong that either I'm not adequately describing or you're not seeing in what I posted.

 

Plus, I've been using this software for many updates and have not had to redo my customiztions for the last several. Why now?

 

To test whether the name change for US made a difference, I reversed and double checked the drop down for the ENVIRONMENT. It does drop down (I missed the first time because it was grayed out) and looks identical to what it did after the US name change.  And again, there is definitely not a DRAFT - EDIT BLOCK choice.

 

I'm going to leave the original US folder as it was and is now. Then I'm going to uninstall ST10 and reinstall. I'll come back and advise.

 

Thanks,

Ron

Betreff: LACK OF MENU CUSTOMIZATION FOR BLOCK/EDIT

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

@ronlatour, I grabbed that [using: Atl + Print Screen] dialogue while in the actual Edit Block mode in Draft....then making a customization.

I would also think there is a direct link to the issue that occurred with the Windows10 "Fall Creators Update", and the way it created a few ongoing problems for Solid Edge, some of which, I'm told Microsoft is still working on.

Sean Cresswell
Design Manager Streetscape Ltd
Solid Edge 2019 [MP2] Classic [x3 Seats - Cloud Enabled]
Windows 10 - Quadro P2000