NPT hole, show mm. instead of inch.

Valued Contributor
Valued Contributor

Hi,

 

A collegue and I and problems with a threaded NPT hole.

We normally (always) use mm. but have to use NPT threaded holes from time to time.

 

The problem is everything has to be defined as inches (in), when we select a NPT hole.

Is it possible to show all measurements/options in milimiters instead of inches? (when selecting NPT)

 

See image for more details.

 

Hope one or more of you will be able to help Smiley Happy

 

NPT holes.png

 

6 REPLIES

Re: NPT hole, show mm. instead of inch.

Legend
Legend

Can you change the ANSI Inch to MM to get what you're looking for?

ST8 MP9
Go FAST, or go home.

Re: NPT hole, show mm. instead of inch.

Valued Contributor
Valued Contributor

No, NPT is not an option when I select ANSI Metric.

 

ansi mm.png

Re: NPT hole, show mm. instead of inch.

Legend
Legend

There are databases for each standard list. I wonder if you couldn't copy your NPT numbers into your mm database and change your dimensions to the appropriate mm numbers. I've not messed with them before, but looks pretty straight forward.

 

program files/solid edge ST7/preferences/holes

 

I make copies of any database before making changes, just in case I screw something up.......

ST8 MP9
Go FAST, or go home.

Re: NPT hole, show mm. instead of inch.

Esteemed Contributor
Esteemed Contributor

Yeah, the values in the Excel tables are read directly into that dialog. It might be desirable to have the program convert them to whatever units are current.

Sounds like an ER is in order.

Bruce Shand
ST9 MP10 - Insight - Win10 - K4200

Re: NPT hole, show mm. instead of inch.

Honored Contributor
Honored Contributor

I have a similar issue in reverse. I do everything in inches, but once in a while I have to mate with metric bolt patterns. Working on a sketch that's inches, I can change the display to MM but the input is still inches.

 

I end up needed to covert and use 7 digits inch equivalent of say 100mm.

 

When working in model sketches, the input should be the same units as is displayed.

 

I think that would solve all the issues.

Re: NPT hole, show mm. instead of inch.

Genius
Genius

A bit of a work around that I use is to use multiply and divide within input box i.e enter 100/25.4 this at least saves getting the calculator out, also works within the hole table for depths etc.